Add libpthread package
authorNicolas Thill <nico@openwrt.org>
Sat, 9 Apr 2005 13:53:37 +0000 (13:53 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 9 Apr 2005 13:53:37 +0000 (13:53 +0000)
SVN-Revision: 600

openwrt/package/libpthread/Config.in [new file with mode: 0644]
openwrt/package/libpthread/Makefile [new file with mode: 0644]
openwrt/package/libpthread/libpthread.control [new file with mode: 0644]

diff --git a/openwrt/package/libpthread/Config.in b/openwrt/package/libpthread/Config.in
new file mode 100644 (file)
index 0000000..87d1a5d
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_LIBPTHREAD
+       tristate "libpthread (POSIX threads library)"
+       default m
+       help
+         POSIX threads library
+         
diff --git a/openwrt/package/libpthread/Makefile b/openwrt/package/libpthread/Makefile
new file mode 100644 (file)
index 0000000..371245f
--- /dev/null
@@ -0,0 +1,36 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME := libpthread
+PKG_VERSION := 0.9.27
+PKG_RELEASE := 1
+
+PKG_SOURCE_DIR := $(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_SOURCE_DIR)
+PKG_IPK := $(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
+PKG_IPK_DIR :=$(PKG_BUILD_DIR)/ipkg/
+
+.NOTPARALLEL:
+
+$(PKG_IPK): $(STAGING_DIR)/lib/libpthread.so
+       rm -rf $(PKG_BUILD_DIR)
+       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+       mkdir -p $(PKG_IPK_DIR)/lib
+       cp -fp $(STAGING_DIR)/lib/libpthread.so.* $(PKG_IPK_DIR)/lib/
+       cp -fp $(STAGING_DIR)/lib/libpthread-*.so $(PKG_IPK_DIR)/lib/
+       $(STRIP) $(PKG_IPK_DIR)/lib/*
+       mkdir -p $(PACKAGE_DIR)
+       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
+
+$(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
+       $(IPKG) install $(PKG_IPK)
+
+source:
+prepare:
+compile: $(PKG_IPK)
+install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
+
+clean:
+       rm -rf $(PKG_BUILD_DIR)
+       rm -f $(PKG_IPK)
diff --git a/openwrt/package/libpthread/libpthread.control b/openwrt/package/libpthread/libpthread.control
new file mode 100644 (file)
index 0000000..7037493
--- /dev/null
@@ -0,0 +1,6 @@
+Package: libpthread
+Priority: optional
+Section: libs
+Maintainer: Nico <nthill@free.fr>
+Source: buildroot internal
+Description: POSIX threads library