[packages] php5: upgrade to 5.4.8 and refresh patches
authorFlorian Fainelli <florian@openwrt.org>
Mon, 21 Jan 2013 15:27:52 +0000 (15:27 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 21 Jan 2013 15:27:52 +0000 (15:27 +0000)
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
SVN-Revision: 35281

lang/php5/Makefile
lang/php5/patches/102-debian_patches_use_embedded_timezonedb.patch

index f7a728c2426e0a4d2e90b19ebc93382a24c6fca9..cc5ef2ba39df6d955309fc7650525541ebb88f03 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
-PKG_VERSION:=5.4.5
-PKG_RELEASE:=4
+PKG_VERSION:=5.4.8
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.php.net/distributions/
-PKG_MD5SUM:=ffcc7f4dcf2b79d667fe0c110e6cb724
+PKG_MD5SUM:=bb8c816a9299be8995255ef70c63b800
 
 PKG_FIXUP:=libtool no-autoreconf
 PKG_BUILD_PARALLEL:=1
index 390910f14d2b21c4e20dcdcb33f13ea4a7c588c2..438274aa153b8d6644fdf597a0efc0df1f509b93 100644 (file)
@@ -67,7 +67,7 @@ r1: initial revision
        /* read BC flag */
        tz->bc = (**tzf == '\1');
        *tzf += 1;
-@@ -256,7 +276,397 @@
+@@ -256,7 +276,397 @@ void timelib_dump_tzinfo(timelib_tzinfo
        }
  }
  
@@ -466,7 +466,7 @@ r1: initial revision
  {
        int left = 0, right = tzdb->index_size - 1;
  #ifdef HAVE_SETLOCALE
-@@ -295,36 +705,128 @@
+@@ -295,36 +705,128 @@ static int seek_to_tz_position(const uns
        return 0;
  }
  
@@ -600,7 +600,7 @@ r1: initial revision
        }
 --- a/ext/date/lib/timelib.m4
 +++ b/ext/date/lib/timelib.m4
-@@ -78,3 +78,17 @@
+@@ -78,3 +78,17 @@ stdlib.h
  
  dnl Check for strtoll, atoll
  AC_CHECK_FUNCS(strtoll atoll strftime)