sync lcd4linux with whiterussian
authorFelix Fietkau <nbd@openwrt.org>
Fri, 20 Jan 2006 03:19:35 +0000 (03:19 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 20 Jan 2006 03:19:35 +0000 (03:19 +0000)
SVN-Revision: 3022

openwrt/package/lcd4linux/Makefile
openwrt/package/lcd4linux/patches/100-drv_RouterBoard.patch [new file with mode: 0644]
openwrt/package/lcd4linux/patches/110-ucdelay.patch [new file with mode: 0644]
openwrt/package/lcd4linux/patches/120-remove_parport_outb.patch [new file with mode: 0644]
openwrt/package/lcd4linux/patches/patch-drv_RouterBoard_c [deleted file]
openwrt/package/lcd4linux/patches/patch-drv_generic_parport_c [deleted file]
openwrt/package/lcd4linux/patches/patch-ucdelay_h [deleted file]

index 04bde6915cb71872396e2a9753d2d8652d8ac269..0d56a62447c1c4d1eec39bbf46e75995cee6e66f 100644 (file)
@@ -3,11 +3,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lcd4linux
-PKG_VERSION:=0.10.0-RC1
+PKG_VERSION:=0.10.0
 PKG_RELEASE:=1
-PKG_MD5SUM:=bab64ac01ebdce7e46ab367351af839f
+PKG_MD5SUM:=b7fb1c24b940482cd730cf212d1b5062
 
-PKG_SOURCE_URL:=@SF/lcd4linux/
+PKG_SOURCE_URL:=@SF/lcd4linux
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_CAT:=zcat
 
diff --git a/openwrt/package/lcd4linux/patches/100-drv_RouterBoard.patch b/openwrt/package/lcd4linux/patches/100-drv_RouterBoard.patch
new file mode 100644 (file)
index 0000000..fc9cbb4
--- /dev/null
@@ -0,0 +1,11 @@
+--- lcd4linux-0.10.0-RC1/drv_RouterBoard.c     2004-08-30 15:20:45.000000000 +0200
++++ lcd-patched/drv_RouterBoard.c      2005-03-19 16:03:26.849650830 +0100
+@@ -113,7 +113,7 @@
+ #include <string.h>
+ #include <errno.h>
+ #include <unistd.h>
+-#include <sys/io.h>
++#include <asm/io.h>
+ #include "debug.h"
+ #include "cfg.h"
diff --git a/openwrt/package/lcd4linux/patches/110-ucdelay.patch b/openwrt/package/lcd4linux/patches/110-ucdelay.patch
new file mode 100644 (file)
index 0000000..0908973
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN lcd4linux.old/udelay.h lcd4linux.dev/udelay.h
+--- lcd4linux.old/udelay.h     2005-05-08 06:32:45.000000000 +0200
++++ lcd4linux.dev/udelay.h     2006-01-20 03:50:36.806897500 +0100
+@@ -76,7 +76,7 @@
+ /* REP NOP (PAUSE) is a good thing to insert into busy-wait loops. */
+ static inline void rep_nop(void)
+ {
+-    __asm__ __volatile__("rep; nop");
++    __asm__ __volatile__("nop");
+ }
diff --git a/openwrt/package/lcd4linux/patches/120-remove_parport_outb.patch b/openwrt/package/lcd4linux/patches/120-remove_parport_outb.patch
new file mode 100644 (file)
index 0000000..3769324
--- /dev/null
@@ -0,0 +1,15 @@
+diff -urN lcd4linux.old/drv_generic_parport.c lcd4linux.dev/drv_generic_parport.c
+--- lcd4linux.old/drv_generic_parport.c        2006-01-20 03:52:18.426419500 +0100
++++ lcd4linux.dev/drv_generic_parport.c        2006-01-20 03:57:59.205263500 +0100
+@@ -134,6 +134,11 @@
+ #define PARPORT_STATUS_BUSY       0x80
+ #endif
++#ifndef WITH_OUTB
++#define inb(foo) 0
++#define outb(foo,bar) 0
++#endif
++ 
+ #if !defined(WITH_OUTB) && !defined(WITH_PPDEV)
+ #error neither outb() nor ppdev() possible
+ #error cannot compile parallel port driver
diff --git a/openwrt/package/lcd4linux/patches/patch-drv_RouterBoard_c b/openwrt/package/lcd4linux/patches/patch-drv_RouterBoard_c
deleted file mode 100644 (file)
index fc9cbb4..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- lcd4linux-0.10.0-RC1/drv_RouterBoard.c     2004-08-30 15:20:45.000000000 +0200
-+++ lcd-patched/drv_RouterBoard.c      2005-03-19 16:03:26.849650830 +0100
-@@ -113,7 +113,7 @@
- #include <string.h>
- #include <errno.h>
- #include <unistd.h>
--#include <sys/io.h>
-+#include <asm/io.h>
- #include "debug.h"
- #include "cfg.h"
diff --git a/openwrt/package/lcd4linux/patches/patch-drv_generic_parport_c b/openwrt/package/lcd4linux/patches/patch-drv_generic_parport_c
deleted file mode 100644 (file)
index f029ffb..0000000
+++ /dev/null
@@ -1,109 +0,0 @@
---- lcd4linux-0.10.0-RC1/drv_generic_parport.c 2005-01-06 17:54:54.000000000 +0100
-+++ lcd/drv_generic_parport.c  2005-03-20 01:20:48.052255953 +0100
-@@ -359,13 +359,12 @@
- #ifdef WITH_PPDEV
-   if (PPdev) {
-     ioctl (PPfd, PPDATADIR, &direction);
--  } else
-+  } 
-+#else
-+      /* code stolen from linux/parport_pc.h */
-+      ctr = (ctr & ~0x20) ^ (direction?0x20:0x00);
-+      outb (ctr, Port+2);
- #endif
--    {
--      /* code stolen from linux/parport_pc.h */
--      ctr = (ctr & ~0x20) ^ (direction?0x20:0x00);
--      outb (ctr, Port+2);
--    }
- }
-@@ -383,11 +382,10 @@
- #ifdef WITH_PPDEV
-   if (PPdev) {
-     ioctl (PPfd, PPRSTATUS, &data);
--  } else
-+  } 
-+#else
-+  data = inb (Port+1);
- #endif
--    {
--      data = inb (Port+1);
--    }
-   
-   /* clear unused bits */
-   data &= mask;
-@@ -413,13 +411,12 @@
-     frob.mask=mask;
-     frob.val=val;
-     ioctl (PPfd, PPFCONTROL, &frob);
--  } else
-+  } 
-+#else
-+  /* code stolen from linux/parport_pc.h */
-+  ctr = (ctr & ~mask) ^ val;
-+  outb (ctr, Port+2);
- #endif
--    {
--      /* code stolen from linux/parport_pc.h */
--      ctr = (ctr & ~mask) ^ val;
--      outb (ctr, Port+2);
--    }
- }
-@@ -456,9 +453,9 @@
-     frob.val = value2;
-     ioctl (PPfd, PPFCONTROL, &frob);
--  } else
--#endif
--    {
-+  } 
-+#else
-+    
-       /* rise */
-       ctr = (ctr & ~bits) ^ value1;
-       outb (ctr, Port+2);
-@@ -469,7 +466,8 @@
-       /* lower */
-       ctr = (ctr & ~bits) ^ value2;
-       outb (ctr, Port+2);
--    }
-+    
-+#endif
- }
-@@ -478,11 +476,11 @@
- #ifdef WITH_PPDEV
-   if (PPdev) {
-     ioctl(PPfd, PPWDATA, &data);
--  } else
-+  } 
-+#else    
-+  outb (data, Port);
- #endif
--    {
--      outb (data, Port);
--    }
-+    
- }
- unsigned char drv_generic_parport_read (void)
-@@ -492,11 +490,10 @@
- #ifdef WITH_PPDEV
-   if (PPdev) {
-     ioctl (PPfd, PPRDATA, &data);
--  } else
-+  } 
-+#else
-+  data=inb (Port);
- #endif
--    {
--      data=inb (Port);
--    }
-   return data;
- }
diff --git a/openwrt/package/lcd4linux/patches/patch-ucdelay_h b/openwrt/package/lcd4linux/patches/patch-ucdelay_h
deleted file mode 100644 (file)
index 619594b..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- lcd4linux-0.10.0-RC1/udelay.h      2004-06-26 14:05:00.000000000 +0200
-+++ lcd-patched/udelay.h       2005-03-19 15:00:54.835892666 +0100
-@@ -69,7 +69,7 @@
- /* REP NOP (PAUSE) is a good thing to insert into busy-wait loops. */
- static inline void rep_nop (void)
- {
--  __asm__ __volatile__("rep; nop");
-+  __asm__ __volatile__("nop");
- }