[package] base-files: another empty password check fix (#10440)
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 17 Nov 2011 09:40:06 +0000 (09:40 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 17 Nov 2011 09:40:06 +0000 (09:40 +0000)
SVN-Revision: 29208

package/base-files/Makefile
package/base-files/files/bin/login.sh

index b93d2cb40262fc7a1b2e3fe33389accc93b6add4..9b3745ba98c0435ea375322423ddd9db1aee3bf7 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=96
+PKG_RELEASE:=97
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 6682b022bad6ff314c36c5b0c0af916227c7bc2b..04b3fe25021b6c3e60c2b298119761e5113c3480 100755 (executable)
@@ -1,7 +1,7 @@
 #!/bin/sh
 # Copyright (C) 2006-2011 OpenWrt.org
 
-if ( ! grep -qs '^root::' /etc/shadow || \
+if ( ! grep -qs '^root:[!x]\?:' /etc/shadow || \
      ! grep -qs '^root:[!x]\?:' /etc/passwd ) && \
    [ -z "$FAILSAFE" ]
 then