Patch to make gettext usable when uClibc is compiled without locale support.This...
authorJohn Crispin <john@openwrt.org>
Tue, 28 Oct 2008 16:31:38 +0000 (16:31 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 28 Oct 2008 16:31:38 +0000 (16:31 +0000)
                support for locale, which is unusable and makes so the gettext library completely unusable on this systems.

SVN-Revision: 13057

libs/gettext/Makefile
libs/gettext/patches/120-uclibc-nolocale.patch [new file with mode: 0644]

index c01303fe360ae1a0f1e9dc2bd863b3fc9e76a889..3686c31689cb04929589a0b969192ee94d71b826 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gettext
 PKG_VERSION:=0.16.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/gettext
diff --git a/libs/gettext/patches/120-uclibc-nolocale.patch b/libs/gettext/patches/120-uclibc-nolocale.patch
new file mode 100644 (file)
index 0000000..2259dcd
--- /dev/null
@@ -0,0 +1,13 @@
+Index: gettext-0.16.1/gettext-runtime/intl/localename.c
+===================================================================
+--- gettext-0.16.1.orig/gettext-runtime/intl/localename.c      2007-12-29 22:51:09.363903016 +0100
++++ gettext-0.16.1/gettext-runtime/intl/localename.c   2008-10-26 16:57:14.048169957 +0100
+@@ -988,7 +988,7 @@
+ {
+   /* Use the POSIX methods of looking to 'LC_ALL', 'LC_xxx', and 'LANG'.
+      On some systems this can be done by the 'setlocale' function itself.  */
+-#if defined HAVE_SETLOCALE && defined HAVE_LC_MESSAGES && defined HAVE_LOCALE_NULL
++#if defined HAVE_SETLOCALE && defined HAVE_LC_MESSAGES && defined HAVE_LOCALE_NULL && (!defined __UCLIBC__ || defined __UCLIBC_HAS_LOCALE__)
+   return setlocale (category, NULL);
+ #else
+   const char *retval;