packages/utils: add cksfv package
authorGabor Juhos <juhosg@openwrt.org>
Tue, 15 Jun 2010 18:51:21 +0000 (18:51 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 15 Jun 2010 18:51:21 +0000 (18:51 +0000)
SVN-Revision: 21810

utils/cksfv/Makefile [new file with mode: 0644]

diff --git a/utils/cksfv/Makefile b/utils/cksfv/Makefile
new file mode 100644 (file)
index 0000000..4cadcbd
--- /dev/null
@@ -0,0 +1,35 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cksfv
+PKG_VERSION:=1.3.14
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://zakalwe.fi/~shd/foss/cksfv/files
+PKG_MD5SUM:=2e15289753ea0b90b6ea86993f93b383
+
+include $(INCLUDE_DIR)/package.mk
+
+define packages/utils/cksfv
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=cksfv CRC32 checksum verification tool
+  URL:=http://zakalwe.fi/~shd/foss/cksfv/
+endef
+
+define packages/utils/cksfv/description
+  cksfv is a tool for verifying CRC32 checksums.
+endef
+
+define packages/utils/cksfv/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/cksfv $(1)/usr/sbin/cksfv
+endef
+
+$(eval $(call BuildPackage,cksfv))