[packages] add netdiscover
authorNicolas Thill <nico@openwrt.org>
Sat, 25 Apr 2009 21:00:56 +0000 (21:00 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 25 Apr 2009 21:00:56 +0000 (21:00 +0000)
SVN-Revision: 15413

net/netdiscover/Makefile [new file with mode: 0644]

diff --git a/net/netdiscover/Makefile b/net/netdiscover/Makefile
new file mode 100644 (file)
index 0000000..639d9e5
--- /dev/null
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=netdiscover
+PKG_VERSION:=0.3-beta6
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://nixgeneration.com/~jaime/netdiscover/releases/
+PKG_MD5SUM:=0919227a91ecaeeb2443cff249417be2
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/netdiscover
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libpcap +libnet1 +libpthread
+  TITLE:=An active/passive address reconnaissance tool
+  URL:=http://nixgeneration.com/~jaime/netdiscover/
+endef
+
+CONFIGURE_VARS+= \
+       CPPFLAGS="$(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/lib/libnet-1.1.x/include" \
+       LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib/libnet-1.1.x/lib" \
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Package/netdiscover/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/netdiscover $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,netdiscover))