CC: toolchain: use latest glibc 2.21 revision
authorJohn Crispin <john@openwrt.org>
Tue, 1 Mar 2016 08:53:27 +0000 (08:53 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 1 Mar 2016 08:53:27 +0000 (08:53 +0000)
Fixes "CVE-2015-7547 --- glibc getaddrinfo() stack-based buffer
overflow"

Signed-off-by: Michael Marley <michael@michaelmarley.com>
SVN-Revision: 48864

toolchain/glibc/Config.version
toolchain/glibc/common.mk
toolchain/glibc/patches/2.21/200-add-dl-search-paths.patch

index 2ac01d7d736eb8beda602123d281d8c20e996280..4ceed09adfcfdb2a2f1c59ab74dbb3ccba5daaaf 100644 (file)
@@ -12,12 +12,6 @@ config EGLIBC_VERSION_2_19
 config GLIBC_VERSION_2_21
        bool
 
 config GLIBC_VERSION_2_21
        bool
 
-config GLIBC_REVISION
-       string
-       default "25243" if EGLIBC_VERSION_2_19
-       default "4e42b5b8f8" if GLIBC_VERSION_2_21
-       default ""
-
 endif
 
 menu "eglibc configuration"
 endif
 
 menu "eglibc configuration"
index 7487ca2782d9068101372b07742e8ed731e13b52..3d680bbcf600f3bc3495d5de92dfccae672d58c1 100644 (file)
@@ -6,9 +6,19 @@
 #
 include $(TOPDIR)/rules.mk
 
 #
 include $(TOPDIR)/rules.mk
 
+
+MD5SUM_2.19 = 42dad4edd3bcb38006d13b5640b00b38
+REVISION_2.19 = 25243
+
+MD5SUM_2.21 = 76050a65c444d58b5c4aa0d6034736ed
+REVISION_2.21 = 16d0a0c
+
+
 PKG_NAME:=glibc
 PKG_VERSION:=$(call qstrip,$(CONFIG_GLIBC_VERSION))
 PKG_NAME:=glibc
 PKG_VERSION:=$(call qstrip,$(CONFIG_GLIBC_VERSION))
-PKG_REVISION:=$(call qstrip,$(CONFIG_GLIBC_REVISION))
+
+PKG_REVISION:=$(REVISION_$(PKG_VERSION))
+PKG_MIRROR_MD5SUM:=$(MD5SUM_$(PKG_VERSION))
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://sourceware.org/git/glibc.git
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://sourceware.org/git/glibc.git
index a6200f783b7030c4a1459f2a0fb1755874df1c19..070f938fe363093cd7e899c6696ade7d579be74d 100644 (file)
@@ -2,7 +2,7 @@ add /usr/lib to default search path for the dynamic linker
 
 --- a/Makeconfig
 +++ b/Makeconfig
 
 --- a/Makeconfig
 +++ b/Makeconfig
-@@ -501,6 +501,9 @@ else
+@@ -499,6 +499,9 @@ else
  default-rpath = $(libdir)
  endif
  
  default-rpath = $(libdir)
  endif