madwifi: fix build against Linux 3.7
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 16 Jan 2013 14:05:27 +0000 (14:05 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 16 Jan 2013 14:05:27 +0000 (14:05 +0000)
SVN-Revision: 35186

net/madwifi/Makefile

index e38d114cd2ec8c5257bed42f66ae5ffb06f5ab24..378bc1b7be7cf5c26b96f2c157a651c786ce5621 100644 (file)
@@ -229,6 +229,8 @@ define Build/Prepare
                $(PKG_BUILD_DIR)/hal/public/arm11*.inc
        $(SED) 's,mtune=arm1136j-s,mtune=mpcore,' \
                $(PKG_BUILD_DIR)/hal/public/arm11*.inc
+       # preset kernel version
+       echo 'char *uts_release = "$(LINUX_VERSION)";' > $(PKG_BUILD_DIR)/kernelversion.c
 endef
 
 ifeq ($(findstring AHB,$(BUS)),AHB)