iptables: install libext*.a into staging dir
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 6 Jun 2013 14:02:24 +0000 (14:02 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 6 Jun 2013 14:02:24 +0000 (14:02 +0000)
SVN-Revision: 36867

package/network/utils/iptables/Makefile

index 55f3a387bde27aac3cc2ec1856c6ecded1c9b6a7..03f692ec68e0326cb88518ce80c04a0fe510ee32 100644 (file)
@@ -375,6 +375,10 @@ define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/xtables.pc $(1)/usr/lib/pkgconfig/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libip*tc.pc $(1)/usr/lib/pkgconfig/
+
+       # XXX: needed by firewall3
+       $(INSTALL_DIR) $(1)/usr/lib/iptables
+       $(CP) $(PKG_BUILD_DIR)/extensions/libext*.a $(1)/usr/lib/iptables/
 endef
 
 define Package/iptables/install