change aiccu section from net to ipv6, standardize
authorNicolas Thill <nico@openwrt.org>
Thu, 19 Oct 2006 18:33:55 +0000 (18:33 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 19 Oct 2006 18:33:55 +0000 (18:33 +0000)
SVN-Revision: 5241

ipv6/aiccu/Makefile [new file with mode: 0644]
ipv6/aiccu/files/aiccu.init [new file with mode: 0644]
net/aiccu/Makefile [deleted file]
net/aiccu/files/aiccu.init [deleted file]

diff --git a/ipv6/aiccu/Makefile b/ipv6/aiccu/Makefile
new file mode 100644 (file)
index 0000000..933bf73
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=aiccu
+PKG_VERSION:=2005.01.31
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
+PKG_MD5SUM:=7c3da5feab3d59fb5a99a45203e0ca56
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/aiccu
+  SECTION:=ipv6
+  CATEGORY:=IPv6
+  TITLE:=SixXS Automatic IPv6 Connectivity Client Utility
+  URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
+endef
+
+define Build/Configure
+       $(SED) "s,strip,$(STRIP)," $(PKG_BUILD_DIR)/unix-console/Makefile
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE" LDFLAGS="-lpthread" DEBUG=0
+endef
+
+define Package/aiccu/install
+       install -d -m0755 $(1)/usr/sbin
+       install -m 755 $(PKG_BUILD_DIR)/unix-console/$(PKG_NAME) $(1)/usr/sbin/
+       install -d -m0755 $(1)/etc
+       install -m 644 $(PKG_BUILD_DIR)/doc/aiccu.conf $(1)/etc/
+       install -d -m0755 $(1)/etc/init.d
+       install -m 755 ./files/aiccu.init $(1)/etc/init.d/aiccu
+endef
+
+$(eval $(call BuildPackage,aiccu))
diff --git a/ipv6/aiccu/files/aiccu.init b/ipv6/aiccu/files/aiccu.init
new file mode 100644 (file)
index 0000000..9f77e19
--- /dev/null
@@ -0,0 +1,10 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2006 OpenWrt.org
+
+start() {
+       aiccu start     
+}
+
+stop() {
+       aiccu stop
+}
diff --git a/net/aiccu/Makefile b/net/aiccu/Makefile
deleted file mode 100644 (file)
index c0b4b3a..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=aiccu
-PKG_VERSION:=2005.01.31
-PKG_RELEASE:=1
-PKG_MD5SUM:=7c3da5feab3d59fb5a99a45203e0ca56
-
-PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
-PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/aiccu
-  SECTION:=net
-  CATEGORY:=Network
-  TITLE:=SixXS Automatic IPv6 Connectivity Client Utility
-  DESCRIPTION:=SixXS Automatic IPv6 Connectivity Client Utility
-  URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
-endef
-
-define Build/Configure
-$(SED) "s,strip,$(STRIP)," $(PKG_BUILD_DIR)/unix-console/Makefile
-endef
-
-define Build/Compile
-        rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE" LDFLAGS="-lpthread" DEBUG=0
-endef
-
-define Package/aiccu/install
-       mkdir -p $(1)/usr/sbin $(1)/etc/init.d
-       install -m 755 $(PKG_BUILD_DIR)/unix-console/$(PKG_NAME) $(1)/usr/sbin/
-       install -m 755 ./files/aiccu.init $(1)/etc/init.d/aiccu
-       install -m 644 $(PKG_BUILD_DIR)/doc/aiccu.conf $(1)/etc/aiccu.conf
-endef
-
-$(eval $(call BuildPackage,aiccu))
diff --git a/net/aiccu/files/aiccu.init b/net/aiccu/files/aiccu.init
deleted file mode 100644 (file)
index 9f77e19..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
-
-start() {
-       aiccu start     
-}
-
-stop() {
-       aiccu stop
-}