add a patch to let our optimization flags override default ones
authorNicolas Thill <nico@openwrt.org>
Mon, 3 Sep 2007 16:00:43 +0000 (16:00 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 3 Sep 2007 16:00:43 +0000 (16:00 +0000)
SVN-Revision: 8599

net/xmail/patches/040-honour_opt_flags.patch [new file with mode: 0644]

diff --git a/net/xmail/patches/040-honour_opt_flags.patch b/net/xmail/patches/040-honour_opt_flags.patch
new file mode 100644 (file)
index 0000000..5440f32
--- /dev/null
@@ -0,0 +1,16 @@
+diff -ruN xmail-1.24-old/Makefile.common xmail-1.24-new/Makefile.common
+--- xmail-1.24-old/Makefile.common     2007-09-01 17:30:57.000000000 +0200
++++ xmail-1.24-new/Makefile.common     2007-09-01 17:34:00.000000000 +0200
+@@ -24,10 +24,10 @@
+ endif
+ ifeq ($(XMAIL_DEBUG), 1)
+-    CFLAGS := $(CFLAGS) -O0 -g
++    CFLAGS := -O0 -g $(CFLAGS)
+     STRIP = touch
+ else
+-    CFLAGS := $(CFLAGS) -O2
++    CFLAGS := -O2 $(CFLAGS)
+ endif
+ OUTDIR = bin