[Packages] net/gpsd:
authorOliver Ertl <oliver@ertl-net.net>
Wed, 13 Feb 2008 10:04:45 +0000 (10:04 +0000)
committerOliver Ertl <oliver@ertl-net.net>
Wed, 13 Feb 2008 10:04:45 +0000 (10:04 +0000)
 * Update 2.35 > 2.36 (closes #3140)
 * Refresh patch

SVN-Revision: 10451

net/gpsd/Makefile
net/gpsd/patches/100-reduce-size.patch

index 49c51e86ab8c5e29aa1eb90a0b2cff119656de10..7560d63fe466c02cd57d7988b91d78e6fa7d9554 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006,2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gpsd
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gpsd
-PKG_VERSION:=2.35
+PKG_VERSION:=2.36
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://download.berlios.de/gpsd/
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://download.berlios.de/gpsd/
-PKG_MD5SUM:=fdd16502f68b997858edd5a9f2fcf9dc
+PKG_MD5SUM:=bb54e89ddb4fdc7af8bbc5534652f9ce
+
+PKG_FIXUP = libtool
 
 PKG_BUILD_DEPENDS=libncurses libnotimpl
 
 
 PKG_BUILD_DEPENDS=libncurses libnotimpl
 
@@ -45,7 +47,7 @@ CONFIGURE_ARGS += \
        --disable-ntpshm \
        --disable-pps \
        --disable-reconfigure \
        --disable-ntpshm \
        --disable-pps \
        --disable-reconfigure \
-       --without-x 
+       --without-x \
 
 CONFIGURE_VARS += \
        CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClic++" \
 
 CONFIGURE_VARS += \
        CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClic++" \
index 15b0fa2d83ec3fb9c948dfe4f7d813fec1c2bdbf..6a508d250cbe91c5b6d05d3f50734784a8fb364f 100644 (file)
@@ -1,6 +1,7 @@
-diff -ru gpsd-2.35-orig/gpsd.c gpsd-2.35/gpsd.c
---- gpsd-2.35-orig/gpsd.c      2007-10-14 20:05:38.000000000 -0700
-+++ gpsd-2.35/gpsd.c   2007-10-15 00:08:36.000000000 -0700
+Index: gpsd-2.36/gpsd.c
+===================================================================
+--- gpsd-2.36.orig/gpsd.c      2008-02-13 11:01:21.000000000 +0100
++++ gpsd-2.36/gpsd.c   2008-02-13 11:01:22.000000000 +0100
 @@ -42,6 +42,7 @@
  #include <locale.h>
  #endif
 @@ -42,6 +42,7 @@
  #include <locale.h>
  #endif
@@ -9,7 +10,7 @@ diff -ru gpsd-2.35-orig/gpsd.c gpsd-2.35/gpsd.c
  #ifdef DBUS_ENABLE
  #include <gpsd_dbus.h>
  #endif
  #ifdef DBUS_ENABLE
  #include <gpsd_dbus.h>
  #endif
-@@ -290,6 +291,7 @@
+@@ -297,6 +298,7 @@
   * This array fills from the bottom, so as an extreme case you could
   * reduce LIMITED_MAX_DEVICES to 1.
   */
   * This array fills from the bottom, so as an extreme case you could
   * reduce LIMITED_MAX_DEVICES to 1.
   */
@@ -17,10 +18,10 @@ diff -ru gpsd-2.35-orig/gpsd.c gpsd-2.35/gpsd.c
  #ifdef LIMITED_MAX_DEVICES
  #define MAXDEVICES    LIMITED_MAX_DEVICES
  #else
  #ifdef LIMITED_MAX_DEVICES
  #define MAXDEVICES    LIMITED_MAX_DEVICES
  #else
-@@ -302,6 +304,7 @@
-  * file descriptors, so don't set this too low. 16 should probably be
-  * the minimum.
-  */
+@@ -304,6 +306,7 @@
+ #define MAXDEVICES    4
+ #endif
 +#define LIMITED_MAX_CLIENTS 16
  #ifdef LIMITED_MAX_CLIENTS
  #define MAXSUBSCRIBERS LIMITED_MAX_CLIENTS
 +#define LIMITED_MAX_CLIENTS 16
  #ifdef LIMITED_MAX_CLIENTS
  #define MAXSUBSCRIBERS LIMITED_MAX_CLIENTS