[packages] openntpd:
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 18 Apr 2011 10:23:50 +0000 (10:23 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 18 Apr 2011 10:23:50 +0000 (10:23 +0000)
- don't check directory permissions, we can't make /var 0700 (#9258)
- fix init script after r26148, use service_kill instead of killall -9 (#9258)
- bump pkg revision

SVN-Revision: 26717

net/openntpd/Makefile
net/openntpd/files/ntpd.init
net/openntpd/patches/003-no_permission_check.patch [new file with mode: 0644]

index fbee724fb603b57eb5a332f8a54f10cf9772747c..980d631f9eccb208291dd2c01b51b39eeaef0d38 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openntpd
 PKG_VERSION:=3.9p1
 
 PKG_NAME:=openntpd
 PKG_VERSION:=3.9p1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenNTPD/ \
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenNTPD/ \
index 31d9f22f03ad28330484e2ff9150e9affc144c77..738007c38ca410db192b99a170a725ff1669b2cd 100644 (file)
@@ -1,5 +1,5 @@
 #!/bin/sh /etc/rc.common
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 
 START=60
 
 
 START=60
 
@@ -8,12 +8,11 @@ boot() {
 }
 
 start() {
 }
 
 start() {
-       mkdir -p `awk -F: '/^ntp:/{print $6}' /etc/passwd`
+       mkdir -p `awk -F: '/^network:/{print $6}' /etc/passwd`
        mkdir -p /var/db/
        /usr/sbin/ntpd -s
 }
 
 stop() {
        mkdir -p /var/db/
        /usr/sbin/ntpd -s
 }
 
 stop() {
-       # -1 seems insufficient to kill one of the two underlying processes.
-       killall -9 ntpd
+       service_kill ntpd
 }
 }
diff --git a/net/openntpd/patches/003-no_permission_check.patch b/net/openntpd/patches/003-no_permission_check.patch
new file mode 100644 (file)
index 0000000..4391a30
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/ntp.c
++++ b/ntp.c
+@@ -111,8 +111,6 @@ ntp_main(int pipe_prnt[2], struct ntpd_c
+       if (stat(chrootdir, &stb) == -1)
+               fatal("stat");
+-      if (stb.st_uid != 0 || (stb.st_mode & (S_IWGRP|S_IWOTH)) != 0)
+-              fatal("bad privsep dir permissions");
+       if (chroot(chrootdir) == -1)
+               fatal("chroot");
+       if (chdir("/") == -1)