port libdaemon to buildroot-ng
authorNicolas Thill <nico@openwrt.org>
Sat, 22 Jul 2006 15:53:04 +0000 (15:53 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 22 Jul 2006 15:53:04 +0000 (15:53 +0000)
SVN-Revision: 4209

libs/libdaemon/Makefile [new file with mode: 0644]

diff --git a/libs/libdaemon/Makefile b/libs/libdaemon/Makefile
new file mode 100644 (file)
index 0000000..4b96c6b
--- /dev/null
@@ -0,0 +1,112 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libdaemon
+PKG_VERSION:=0.10
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://0pointer.de/lennart/projects/libdaemon/
+PKG_MD5SUM:=6812a5e4063b5016f25e9a0cebbd3dd9
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libdaemon
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=A lightweight C library that eases the writing of UNIX daemons
+  DESCRIPTION:=A lightweight C library that eases the writing of UNIX daemons.\\\
+    libdaemon is a lightweight C library that eases the writing of UNIX daemons.\\\
+    It consists of the following parts:\\\
+    \\\
+      * A wrapper around fork() which does the correct daemonization procedure of a process\\\
+      * A wrapper around syslog() for simpler and compatible log output to Syslog or STDERR\\\
+      * An API for writing PID files\\\
+      * An API for serializing UNIX signals into a pipe for usage with select() or poll()\\\
+      * An API for running subprocesses with STDOUT and STDERR redirected to syslog\\\
+    \\\
+    APIs like these are used in most daemon software available. It is not that \\\
+    simple to get it done right and code duplication is not a goal.
+  URL:=http://0pointer.de/lennart/projects/libdaemon/
+endef
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               ac_cv_func_setpgrp_void=yes \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --enable-shared \
+                       --enable-static \
+                       --disable-rpath \
+                       --with-gnu-ld \
+                       --disable-lynx \
+       );
+endef
+
+define Build/Compile
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Package/libdaemon/install
+       install -d -m0755 $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdaemon.so.* $(1)/usr/lib/
+endef
+
+define Build/InstallDev
+       mkdir -p $(STAGING_DIR)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/libdaemon $(STAGING_DIR)/usr/include/
+       mkdir -p $(STAGING_DIR)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdaemon.a $(STAGING_DIR)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdaemon.so* $(STAGING_DIR)/usr/lib/
+       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libdaemon.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+       $(SED) 's,-I$${includedir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/libdaemon.pc
+       $(SED) 's,-L$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/libdaemon.pc
+endef
+
+define Build/UninstallDev
+       rm -rf \
+               $(STAGING_DIR)/usr/include/libdaemon \
+               $(STAGING_DIR)/usr/lib/libdaemon.a \
+               $(STAGING_DIR)/usr/lib/libdaemon.so* \
+               $(STAGING_DIR)/usr/lib/pkgconfig/libdaemon.pc
+endef
+
+$(eval $(call BuildPackage,libdaemon))