Added ipcad
authorFlorian Fainelli <florian@openwrt.org>
Sat, 17 Dec 2005 17:19:53 +0000 (17:19 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 17 Dec 2005 17:19:53 +0000 (17:19 +0000)
SVN-Revision: 2714

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/ipcad/Config.in [new file with mode: 0755]
openwrt/package/ipcad/Makefile [new file with mode: 0755]
openwrt/package/ipcad/ipkg/ipcad.control [new file with mode: 0755]

index 21316ea754cab9b5cd874a737eccb6817e9beb12..5667689f3648da1eeb9f47a71557db1c6b3d3643 100644 (file)
@@ -69,6 +69,7 @@ source "package/howl/Config.in"
 source "package/hostap-utils/Config.in"
 source "package/hostapd/Config.in"
 source "package/htpdate/Config.in"
+source "package/ipcad/Config.in"
 source "package/iproute2/Config.in"
 source "package/iperf/Config.in"
 source "package/ipsec-tools/Config.in"
index 548f002bff25bf494155bee6b14f5a9520e94aec..4c625ddb124f481bc64726a4747c8c5f42cf8d24 100644 (file)
@@ -60,6 +60,7 @@ package-$(BR2_COMPILE_HOWL) += howl
 package-$(BR2_PACKAGE_HTPDATE) += htpdate
 package-$(BR2_PACKAGE_ICECAST) += icecast
 package-$(BR2_PACKAGE_ID3LIB) += id3lib
+package-$(BR2_PACKAGE_IPCAD) += ipcad
 package-$(BR2_PACKAGE_IPERF) += iperf
 package-$(BR2_PACKAGE_IPKG) += ipkg
 package-$(BR2_COMPILE_IPROUTE2) += iproute2
@@ -267,6 +268,7 @@ gnutls-compile: libgcrypt-compile opencdk-compile libtasn1-compile
 gpsd-compile: uclibc++-compile
 icecast-compile: curl-compile libvorbisidec-compile libxml2-compile libxslt-compile
 id3lib-compile: uclibc++-compile zlib-compile
+ipcad-compile: libpcap-compile
 irssi-compile: glib-compile ncurses-compile
 iperf-compile: uclibc++-compile
 iptables-snmp-compile: net-snmp-compile
diff --git a/openwrt/package/ipcad/Config.in b/openwrt/package/ipcad/Config.in
new file mode 100755 (executable)
index 0000000..c38731f
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_IPCAD
+        tristate "ipcad............................. listens for traffic on the specified interfaces"
+               default m if CONFIG_DEVEL
+               select BR2_PACKAGE_LIBPCAP
+               help
+                       This daemon listens for traffic on the specified interfaces.
+                       It has the built-in RSH and NetFlow engines to allow exporting
+                       the accounting data the same way as Cisco routers do.
+                       
+                       http://lionet.info/ipcad/
diff --git a/openwrt/package/ipcad/Makefile b/openwrt/package/ipcad/Makefile
new file mode 100755 (executable)
index 0000000..f49ac7e
--- /dev/null
@@ -0,0 +1,53 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ipcad
+PKG_VERSION:=3.7
+PKG_RELEASE:=1
+PKG_MD5SUM:=34c542c99593dfe9d5b408deffcfe70e
+PKG_SOURCE_URL:=@SF/ipcad
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,IPCAD,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+                $(TARGET_CONFIGURE_OPTS) \
+                CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -L$(STAGING_DIR)/usr/lib" \
+                ./configure \
+                --target=$(GNU_TARGET_NAME) \
+                --host=$(GNU_TARGET_NAME) \
+                --build=$(GNU_HOST_NAME) \
+                --prefix=/usr \
+                --exec-prefix=/usr \
+                --bindir=/usr/bin \
+                --sbindir=/usr/sbin \
+                --libexecdir=/usr/lib \
+                --sysconfdir=/etc \
+                --datadir=/usr/share \
+                --localstatedir=/var \
+                --mandir=/usr/man \
+               --mandir=/usr/man \
+                --infodir=/usr/info \
+                --program-prefix="" \
+               --with-gnu-ld \
+               --with-psrc=pcap \
+               --with-pcap-include=$(STAGING_DIR)/usr/include \
+               --with-pcap-libraries=$(STAGING_DIR)/usr/lib \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) STAGING_DIR=$(STAGING_DIR) DESTDIR=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR) all install-bin install-conf
+       touch $@
+
+$(IPKG_IPCAD):
+       mkdir -p $(IDIR_IPCAD)
+       cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_IPCAD)/
+       $(RSTRIP) $(IDIR_IPCAD)
+       $(IPKG_BUILD) $(IDIR_IPCAD) $(PACKAGE_DIR)
diff --git a/openwrt/package/ipcad/ipkg/ipcad.control b/openwrt/package/ipcad/ipkg/ipcad.control
new file mode 100755 (executable)
index 0000000..93df70c
--- /dev/null
@@ -0,0 +1,6 @@
+Package: ipcad
+Depends: libpcap
+Section: net
+Architecture: mipsel
+Priority: optional
+Description: IPCAD stands for IP Cisco Accounting Daemon. It runs in background, listens traffic on the specified interfaces, and records the traffic for later retrieval and analysis. IPCAD can use raw BPF devices, PCAP library, divert, tee or Linux iptables' ULOG & IPQ packet sources to capture the packets.