[package] update muninlite to 1.0.2, fix xined dependency (#5291)
authorFlorian Fainelli <florian@openwrt.org>
Mon, 8 Jun 2009 21:14:57 +0000 (21:14 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 8 Jun 2009 21:14:57 +0000 (21:14 +0000)
SVN-Revision: 16389

admin/muninlite/Makefile
admin/muninlite/patches/001-no_disks.patch
admin/muninlite/patches/002-add_ppp.patch [deleted file]

index 347da04f82056f82c21a89ba56addb6b5c63bb8c..f60b73787543a2369b1b3688e6bc3e5b9d7d207b 100644 (file)
@@ -8,19 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=muninlite
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=muninlite
-PKG_VERSION:=1.0.0
-PKG_RELEASE:=2
+PKG_VERSION:=1.0.2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=d8824bd98300fa6b1bf4aa6af08b7e39
+PKG_MD5SUM:=67fe45999fbd29f7d91fe342889e3dcb
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/muninlite
   SECTION:=admin
   CATEGORY:=Administration
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/muninlite
   SECTION:=admin
   CATEGORY:=Administration
-  DEPENDS:=xinetd
+  DEPENDS:=+xinetd
   TITLE:=Munin node implemented in shell
   URL:=http://sourceforge.net/projects/muninlite/
 endef
   TITLE:=Munin node implemented in shell
   URL:=http://sourceforge.net/projects/muninlite/
 endef
index 4833fcd9f6a21f4462813ef5f20d752b548a33de..d24e2303a4e72881d0164aca7107208d4626c840 100644 (file)
@@ -1,20 +1,12 @@
-diff -Naur muninlite-1.0.0/Makefile muninlite-1.0.0-openwrt/Makefile
---- muninlite-1.0.0/Makefile   2007-06-15 14:00:12.000000000 +0200
-+++ muninlite-1.0.0-openwrt/Makefile   2008-05-13 14:15:47.000000000 +0200
+--- a/Makefile
++++ b/Makefile
 @@ -1,7 +1,7 @@
  
  
 @@ -1,7 +1,7 @@
  
  
--PLUGINS=df cpu if_ if_err_ load memory processes swap netstat uptime interrupts irqstats
+-PLUGINS=df cpu if_ if_err_ load memory processes swap netstat uptime interrupts irqstats ntpdate
 -#PLUGINS=cpu if_ if_err_ load memory processes netstat uptime interrupts irqstats
 -#PLUGINS=cpu if_ if_err_ load memory processes netstat uptime interrupts irqstats
-+#PLUGINS=df cpu if_ if_err_ load memory processes swap netstat uptime interrupts irqstats
++#PLUGINS=df cpu if_ if_err_ load memory processes swap netstat uptime interrupts irqstats ntpdate
 +PLUGINS=cpu if_ if_err_ load memory processes netstat uptime interrupts irqstats
  
 +PLUGINS=cpu if_ if_err_ load memory processes netstat uptime interrupts irqstats
  
- munin-node: plugins/*
+ munin-node: plugins/* munin-node.conf
        @VERSION=$$(cat VERSION); \
        @VERSION=$$(cat VERSION); \
-@@ -43,4 +43,4 @@
-       cd releases; \
-       rm -rf  muninlite-$$VERSION/releases; \
-       tar zcvf muninlite-$$VERSION.tar.gz muninlite-$$VERSION >/dev/null; \
--      rm -rf  muninlite-$$VERSION;
-\ No newline at end of file
-+      rm -rf  muninlite-$$VERSION;
diff --git a/admin/muninlite/patches/002-add_ppp.patch b/admin/muninlite/patches/002-add_ppp.patch
deleted file mode 100644 (file)
index 85940af..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -Naur muninlite-1.0.0/munin-node.in muninlite-1.0.0-openwrt/munin-node.in
---- muninlite-1.0.0/munin-node.in      2007-06-11 20:30:26.000000000 +0200
-+++ muninlite-1.0.0-openwrt/munin-node.in      2008-05-13 14:14:25.000000000 +0200
-@@ -62,14 +62,14 @@
- for PLUG in $PLUGINS
- do 
-   if [ "$PLUG" = "if_" ]; then  
--    for INTER in $(grep '^ *\(eth\|wlan\|ath\|ra\)[0-9]\{1,\}:' /proc/net/dev | cut -f1 -d: | sed 's/ //g');
-+    for INTER in $(grep '^ *\(ppp\|eth\|wlan\|ath\|ra\)[0-9]\{1,\}:' /proc/net/dev | cut -f1 -d: | sed 's/ //g');
-     do
-       RES="$RES if_$INTER"
-       eval "fetch_if_${INTER}() { fetch_if $INTER $@; };"
-       eval "config_if_${INTER}() { config_if $INTER $@; };"
-     done
-   elif [ "$PLUG" = "if_err_" ]; then
--    for INTER in $(grep '^ *\(eth\|wlan\|ath\|ra\)[0-9]\{1,\}:' /proc/net/dev | cut -f1 -d: | sed 's/ //g');
-+    for INTER in $(grep '^ *\(ppp\|eth\|wlan\|ath\|ra\)[0-9]\{1,\}:' /proc/net/dev | cut -f1 -d: | sed 's/ //g');
-     do
-       RES="$RES if_err_$INTER"
-       eval "fetch_if_err_${INTER}() { fetch_if_err $INTER $@; };"