[packages] vsftpd: compile with target optimizations
authorNicolas Thill <nico@openwrt.org>
Sat, 25 Apr 2009 21:03:43 +0000 (21:03 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 25 Apr 2009 21:03:43 +0000 (21:03 +0000)
SVN-Revision: 15414

net/vsftpd/Makefile

index cce7311342b0f58b4e8c28458a1e2fc4ad72b89c..59aaf10036770c9cce116327b29b244147f6f370 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vsftpd
 PKG_VERSION:=2.1.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://vsftpd.beasts.org/users/cevans/
@@ -29,6 +29,13 @@ define Package/vsftpd/conffiles
 /etc/vsftpd.conf
 endef
 
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               vsftpd
+endef
+
 define Package/vsftpd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/