[uml] update to 2.6.38
authorFlorian Fainelli <florian@openwrt.org>
Mon, 2 May 2011 07:57:25 +0000 (07:57 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 2 May 2011 07:57:25 +0000 (07:57 +0000)
SVN-Revision: 26803

target/linux/generic/config-2.6.38
target/linux/uml/Makefile
target/linux/uml/config/i386
target/linux/uml/config/x86_64
target/linux/uml/patches-2.6.38/001-gcc4_unit_at_a_time_i386_fix.patch [new file with mode: 0644]
target/linux/uml/patches-2.6.38/002-gcc4_unfortify_source.patch [new file with mode: 0644]
target/linux/uml/patches-2.6.38/006-uml_libc_link_errors.patch [new file with mode: 0644]
target/linux/uml/patches-2.6.38/901-lib_zlib_deflate_visible.patch [new file with mode: 0644]

index 6c1fb037a67d62d1756ddf16d3e71e4d8bcd5335..6697c9e6bc1b509166eeabf21dcd50f67d04b3d4 100644 (file)
@@ -587,6 +587,7 @@ CONFIG_EPOLL=y
 # CONFIG_ETHOC is not set
 CONFIG_EVENTFD=y
 CONFIG_EXPERIMENTAL=y
+CONFIG_EXPERT=y
 # CONFIG_EXPORTFS is not set
 # CONFIG_EXT2_FS is not set
 # CONFIG_EXT2_FS_XATTR is not set
index 9342b1fa90674bcfb9bb3bb2b0b19446ee61f93d..442b71656c13ed0d1eafc15bf7045ce7fdc79aad 100644 (file)
@@ -22,7 +22,7 @@ BOARD:=uml
 BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 
-LINUX_VERSION:=2.6.37.6
+LINUX_VERSION:=2.6.38.2
 
 include $(INCLUDE_DIR)/target.mk
 
index fb2b0cb251c4513a5934fb4ff93edd204881fef6..71246861cd93da79361b38471c7795c67b1eb617 100644 (file)
@@ -101,6 +101,7 @@ CONFIG_POSIX_MQUEUE_SYSCTL=y
 # CONFIG_PREEMPT_RCU is not set
 CONFIG_PRINT_QUOTA_WARNING=y
 CONFIG_PROC_PAGE_MONITOR=y
+# CONFIG_PROCESSOR_SELECT is not set
 CONFIG_PTY_CHAN=y
 CONFIG_QFMT_V1=y
 CONFIG_QFMT_V2=y
index 006f4541681152baba33a4dd0c4b9dff3230c45f..39445c269a21d155306274ec7339f3a2d1b5bafb 100644 (file)
@@ -82,6 +82,7 @@ CONFIG_POSIX_MQUEUE_SYSCTL=y
 # CONFIG_PREEMPT_RCU is not set
 # CONFIG_PRINT_QUOTA_WARNING is not set
 CONFIG_PROC_PAGE_MONITOR=y
+# CONFIG_PROCESSOR_SELECT is not set
 CONFIG_PTY_CHAN=y
 CONFIG_QFMT_V1=y
 CONFIG_QFMT_V2=y
diff --git a/target/linux/uml/patches-2.6.38/001-gcc4_unit_at_a_time_i386_fix.patch b/target/linux/uml/patches-2.6.38/001-gcc4_unit_at_a_time_i386_fix.patch
new file mode 100644 (file)
index 0000000..442c0ec
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/arch/um/Makefile-i386
++++ b/arch/um/Makefile-i386
+@@ -35,7 +35,7 @@ cflags-y += -ffreestanding
+ # Disable unit-at-a-time mode on pre-gcc-4.0 compilers, it makes gcc use
+ # a lot more stack due to the lack of sharing of stacklots.  Also, gcc
+ # 4.3.0 needs -funit-at-a-time for extern inline functions.
+-KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0400 ] ; then \
++KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0403 ] ; then \
+                       echo $(call cc-option,-fno-unit-at-a-time); \
+                       else echo $(call cc-option,-funit-at-a-time); fi ;)
diff --git a/target/linux/uml/patches-2.6.38/002-gcc4_unfortify_source.patch b/target/linux/uml/patches-2.6.38/002-gcc4_unfortify_source.patch
new file mode 100644 (file)
index 0000000..2be33d0
--- /dev/null
@@ -0,0 +1,21 @@
+--- a/arch/um/Makefile-i386
++++ b/arch/um/Makefile-i386
+@@ -39,4 +39,8 @@ KBUILD_CFLAGS += $(shell if [ $(call cc-
+                       echo $(call cc-option,-fno-unit-at-a-time); \
+                       else echo $(call cc-option,-funit-at-a-time); fi ;)
++# disable compile-time buffer checks, enabled by default on Ubuntu 8.10 
++# and later
++KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
++
+ KBUILD_CFLAGS += $(cflags-y)
+--- a/arch/um/Makefile-x86_64
++++ b/arch/um/Makefile-x86_64
+@@ -24,3 +24,7 @@ LINK-y += -m64
+ # Do unit-at-a-time unconditionally on x86_64, following the host
+ KBUILD_CFLAGS += $(call cc-option,-funit-at-a-time)
++
++# disable compile-time buffer checks, enabled by default on Ubuntu 8.10 
++# and later
++KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
diff --git a/target/linux/uml/patches-2.6.38/006-uml_libc_link_errors.patch b/target/linux/uml/patches-2.6.38/006-uml_libc_link_errors.patch
new file mode 100644 (file)
index 0000000..0bab54c
--- /dev/null
@@ -0,0 +1,24 @@
+--- a/arch/um/kernel/uml.lds.S
++++ b/arch/um/kernel/uml.lds.S
+@@ -35,6 +35,21 @@ SECTIONS
+     *(.gnu.warning)
+     *(.gnu.linkonce.t*)
+   }
++  /* Deal with multilib libc */
++  .rel.plt        :
++  {
++    *(.rel.plt)
++    PROVIDE_HIDDEN (__rel_iplt_start = .);
++    *(.rel.iplt)
++    PROVIDE_HIDDEN (__rel_iplt_end = .);
++  }
++  .rela.plt       :
++  {
++    *(.rela.plt)
++    PROVIDE_HIDDEN (__rela_iplt_start = .);
++    *(.rela.iplt)
++    PROVIDE_HIDDEN (__rela_iplt_end = .);
++  }
+   . = ALIGN(PAGE_SIZE);
+   .syscall_stub : {
diff --git a/target/linux/uml/patches-2.6.38/901-lib_zlib_deflate_visible.patch b/target/linux/uml/patches-2.6.38/901-lib_zlib_deflate_visible.patch
new file mode 100644 (file)
index 0000000..f4aba9b
--- /dev/null
@@ -0,0 +1,14 @@
+make ZLIB_DEFLATE visible, so that we can choose whether we want it built-in
+or as a module
+
+--- a/lib/Kconfig
++++ b/lib/Kconfig
+@@ -98,7 +98,7 @@ config ZLIB_INFLATE
+       tristate
+ config ZLIB_DEFLATE
+-      tristate
++      tristate "Zlib compression"
+ config LZO_COMPRESS
+       tristate