[omap35xx]: Add new defconfig and profile for es variant
authorHamish Guthrie <hcg@openwrt.org>
Fri, 13 May 2011 11:49:52 +0000 (11:49 +0000)
committerHamish Guthrie <hcg@openwrt.org>
Fri, 13 May 2011 11:49:52 +0000 (11:49 +0000)
SVN-Revision: 26884

target/linux/omap35xx/gumstix/defconfig.es [new file with mode: 0644]
target/linux/omap35xx/gumstix/profiles/002-es.mk [new file with mode: 0644]

diff --git a/target/linux/omap35xx/gumstix/defconfig.es b/target/linux/omap35xx/gumstix/defconfig.es
new file mode 100644 (file)
index 0000000..8a139a8
--- /dev/null
@@ -0,0 +1,28 @@
+# defconfig for energy station
+
+CONFIG_TARGET_omap35xx=y
+CONFIG_TARGET_omap35xx_gumstix=y
+CONFIG_TARGET_omap35xx_gumstix_Es=y
+CONFIG_DEVEL=y
+CONFIG_BROKEN=y
+CONFIG_TOOLCHAINOPTS=y
+CONFIG_GCC_VERSION_4_4_5=y
+CONFIG_INSTALL_LIBSTDCPP=y
+CONFIG_TARGET_OPTIONS=y
+CONFIG_TARGET_OPTIMIZATION="-O2 -pipe -march=armv7-a -mtune=cortex-a8 -funit-at-a-time"
+CONFIG_USE_UCLIBC=y
+CONFIG_UCLIBC_VERSION_0_9_30_1=y
+CONFIG_TARGET_ROOTFS_PARTSIZE=200
+CONFIG_SOFT_FLOAT=n
+CONFIG_TARGET_ROOTFS_EXT4FS=y
+CONFIG_UDEV_EXTRA_firmware=y
+CONFIG_IMAGEOPT=y
+CONFIG_UCI_PRECONFIG_network_lan_proto="dhcp"
+CONFIG_UCI_PRECONFIG_network_lan_netmask=""
+CONFIG_UCI_PRECONFIG_network_lan_ipaddr=""
+CONFIG_BUSYBOX_CONFIG_STTY=y
+CONFIG_BUSYBOX_CONFIG_TTY=y
+CONFIG_PACKAGE_es=y
+CONFIG_PACKAGE_es_sentec_real=y
+CONFIG_PACKAGE_es_sentec_sim=y
+CONFIG_PACKAGE_estest=y
diff --git a/target/linux/omap35xx/gumstix/profiles/002-es.mk b/target/linux/omap35xx/gumstix/profiles/002-es.mk
new file mode 100644 (file)
index 0000000..78386f6
--- /dev/null
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2006 - 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Es
+  NAME:=es
+  PACKAGES:=-iptables -ppp -ppp-mod-pppoe -kmod-ipt-nathelper \
+               -firewall -mtd -hotplug2 -udevtrigger -dropbear \
+               usb udev kmod-bluetooth ntpclient wpa-supplicant \
+               wireless-tools wpa-cli \
+               bluez-utils bluez-hcidump usbutils \
+               kmod-usb-serial kmod-usb-serial-cp210x kmod-usb-serial-ftdi \
+               kmod-usb-serial-pl2303 kmod-usb-uhci kmod-cfg80211 \
+               kmod-lib80211 kmod-libertas-sd kmod-mac80211 libnl-tiny \
+               crda iw kmod-usb-hid \
+               kmod-usb-storage kmod-usb-storage-extras kmod-fs-vfat \
+               uboot-omap35xx-omap3_overo \
+               es estest mtd-utils uboot-envtools
+endef
+
+define Profile/Es/Description
+        Gumstix www.gumstix.com
+endef
+$(eval $(call Profile,Es))