Fix freeradius compilation when not selecting all EAP modules (#1373)
authorFlorian Fainelli <florian@openwrt.org>
Tue, 27 Feb 2007 10:09:36 +0000 (10:09 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 27 Feb 2007 10:09:36 +0000 (10:09 +0000)
SVN-Revision: 6398

net/freeradius/Makefile

index 7493dc16471c44d735689e6ea4729e6ca2d802b6..cf7b537ad5aa8c41e61acf1a486343fde23bfba7 100644 (file)
@@ -271,6 +271,18 @@ else
   PKG_CONFIGURE_OPTIONS+= --without-rlm_sql_postgresql
 endif
 
   PKG_CONFIGURE_OPTIONS+= --without-rlm_sql_postgresql
 endif
 
+ifeq ($(CONFIG_PACKAGE_freeradius-mod-eap-tls),)
+  PKG_CONFIGURE_OPTIONS+= --without-rlm_eap_tls
+endif
+
+ifeq ($(CONFIG_PACKAGE_freeradius-mod-eap-peap),)
+  PKG_CONFIGURE_OPTIONS+= --without-rlm_eap_peap
+endif
+
+ifeq ($(CONFIG_PACKAGE_freeradius-mod-eap-ttls),)
+  PKG_CONFIGURE_OPTIONS+= --without-rlm_eap_ttls
+endif
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --libdir=/usr/lib/freeradius \
 define Build/Configure
        $(call Build/Configure/Default, \
                --libdir=/usr/lib/freeradius \