fix bind compile error
authorFelix Fietkau <nbd@openwrt.org>
Sat, 14 Oct 2006 23:42:00 +0000 (23:42 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 14 Oct 2006 23:42:00 +0000 (23:42 +0000)
SVN-Revision: 5107

net/bind/patches/100-cross_compile.patch [new file with mode: 0644]
net/bind/patches/110-host_build_fix.patch [new file with mode: 0644]
net/bind/patches/cross-compile.patch [deleted file]

diff --git a/net/bind/patches/100-cross_compile.patch b/net/bind/patches/100-cross_compile.patch
new file mode 100644 (file)
index 0000000..c8187c6
--- /dev/null
@@ -0,0 +1,220 @@
+diff -urN bind-9.3.1/configure bind-9.3.1.new/configure
+--- bind-9.3.1/configure       2004-12-09 05:09:03.000000000 +0100
++++ bind-9.3.1.new/configure   2006-07-31 14:24:19.000000000 +0200
+@@ -4750,7 +4750,7 @@
+   use_openssl="auto"
+ fi;
+-openssldirs="/usr /usr/local /usr/local/ssl /usr/pkg"
++openssldirs="-I$STAGING_DIR/usr/include"
+ if test "$use_openssl" = "auto"
+ then
+       for d in $openssldirs
+@@ -5289,6 +5289,7 @@
+ if eval "test \"\${$as_ac_File+set}\" = set"; then
+   echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
++cross_compiling=no
+   test "$cross_compiling" = yes &&
+   { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+ echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+@@ -23675,175 +23676,6 @@
+ # which provides some (all?) of the desired functions.
+ #
+-echo "$as_me:$LINENO: checking for inet_ntop with IPv6 support" >&5
+-echo $ECHO_N "checking for inet_ntop with IPv6 support... $ECHO_C" >&6
+-if test "$cross_compiling" = yes; then
+-  { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
+-See \`config.log' for more details." >&5
+-echo "$as_me: error: cannot run test program while cross compiling
+-See \`config.log' for more details." >&2;}
+-   { (exit 1); exit 1; }; }
+-else
+-  cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h.  */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h.  */
+-
+-#include <sys/types.h>
+-#include <sys/socket.h>
+-#include <netinet/in.h>
+-#include <arpa/inet.h>
+-main() {
+-char a[16],b[64]; return(inet_ntop(AF_INET6, a, b, sizeof(b)) == (char*)0);}
+-_ACEOF
+-rm -f conftest$ac_exeext
+-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+-  (eval $ac_link) 2>&5
+-  ac_status=$?
+-  echo "$as_me:$LINENO: \$? = $ac_status" >&5
+-  (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
+-  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+-  (eval $ac_try) 2>&5
+-  ac_status=$?
+-  echo "$as_me:$LINENO: \$? = $ac_status" >&5
+-  (exit $ac_status); }; }; then
+-  echo "$as_me:$LINENO: result: yes" >&5
+-echo "${ECHO_T}yes" >&6
+-        ISC_PLATFORM_NEEDNTOP="#undef ISC_PLATFORM_NEEDNTOP"
+-else
+-  echo "$as_me: program exited with status $ac_status" >&5
+-echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+-( exit $ac_status )
+-echo "$as_me:$LINENO: result: no" >&5
+-echo "${ECHO_T}no" >&6
+-        ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_ntop.$O"
+-        ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_ntop.c"
+-        ISC_PLATFORM_NEEDNTOP="#define ISC_PLATFORM_NEEDNTOP 1"
+-fi
+-rm -f core *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
+-fi
+-
+-
+-# On NetBSD 1.4.2 and maybe others, inet_pton() incorrectly accepts
+-# addresses with less than four octets, like "1.2.3".  Also leading
+-# zeros should also be rejected.
+-
+-echo "$as_me:$LINENO: checking for working inet_pton with IPv6 support" >&5
+-echo $ECHO_N "checking for working inet_pton with IPv6 support... $ECHO_C" >&6
+-if test "$cross_compiling" = yes; then
+-  echo "$as_me:$LINENO: result: assuming target platform has working inet_pton" >&5
+-echo "${ECHO_T}assuming target platform has working inet_pton" >&6
+-      ISC_PLATFORM_NEEDPTON="#undef ISC_PLATFORM_NEEDPTON"
+-else
+-  cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h.  */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h.  */
+-
+-#include <sys/types.h>
+-#include <sys/socket.h>
+-#include <netinet/in.h>
+-#include <arpa/inet.h>
+-main() { char a[16]; return (inet_pton(AF_INET, "1.2.3", a) == 1 ? 1 :
+-                           inet_pton(AF_INET, "1.2.3.04", a) == 1 ? 1 :
+-                           (inet_pton(AF_INET6, "::1.2.3.4", a) != 1)); }
+-_ACEOF
+-rm -f conftest$ac_exeext
+-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+-  (eval $ac_link) 2>&5
+-  ac_status=$?
+-  echo "$as_me:$LINENO: \$? = $ac_status" >&5
+-  (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
+-  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+-  (eval $ac_try) 2>&5
+-  ac_status=$?
+-  echo "$as_me:$LINENO: \$? = $ac_status" >&5
+-  (exit $ac_status); }; }; then
+-  echo "$as_me:$LINENO: result: yes" >&5
+-echo "${ECHO_T}yes" >&6
+-        ISC_PLATFORM_NEEDPTON="#undef ISC_PLATFORM_NEEDPTON"
+-else
+-  echo "$as_me: program exited with status $ac_status" >&5
+-echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+-( exit $ac_status )
+-echo "$as_me:$LINENO: result: no" >&5
+-echo "${ECHO_T}no" >&6
+-        ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_pton.$O"
+-        ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_pton.c"
+-        ISC_PLATFORM_NEEDPTON="#define ISC_PLATFORM_NEEDPTON 1"
+-fi
+-rm -f core *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
+-fi
+-
+-echo "$as_me:$LINENO: checking for inet_aton" >&5
+-echo $ECHO_N "checking for inet_aton... $ECHO_C" >&6
+-cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h.  */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h.  */
+-
+-#include <sys/types.h>
+-#include <netinet/in.h>
+-#include <arpa/inet.h>
+-int
+-main ()
+-{
+-struct in_addr in; inet_aton(0, &in); return (0);
+-  ;
+-  return 0;
+-}
+-_ACEOF
+-rm -f conftest.$ac_objext conftest$ac_exeext
+-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+-  (eval $ac_link) 2>conftest.er1
+-  ac_status=$?
+-  grep -v '^ *+' conftest.er1 >conftest.err
+-  rm -f conftest.er1
+-  cat conftest.err >&5
+-  echo "$as_me:$LINENO: \$? = $ac_status" >&5
+-  (exit $ac_status); } &&
+-       { ac_try='test -z "$ac_c_werror_flag"
+-                       || test ! -s conftest.err'
+-  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+-  (eval $ac_try) 2>&5
+-  ac_status=$?
+-  echo "$as_me:$LINENO: \$? = $ac_status" >&5
+-  (exit $ac_status); }; } &&
+-       { ac_try='test -s conftest$ac_exeext'
+-  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+-  (eval $ac_try) 2>&5
+-  ac_status=$?
+-  echo "$as_me:$LINENO: \$? = $ac_status" >&5
+-  (exit $ac_status); }; }; then
+-  echo "$as_me:$LINENO: result: yes" >&5
+-echo "${ECHO_T}yes" >&6
+-        ISC_PLATFORM_NEEDATON="#undef ISC_PLATFORM_NEEDATON"
+-else
+-  echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+-echo "$as_me:$LINENO: result: no" >&5
+-echo "${ECHO_T}no" >&6
+-        ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_aton.$O"
+-        ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_aton.c"
+-        ISC_PLATFORM_NEEDATON="#define ISC_PLATFORM_NEEDATON 1"
+-fi
+-rm -f conftest.err conftest.$ac_objext \
+-      conftest$ac_exeext conftest.$ac_ext
+-
+-
+-
+-
+ #
+ # Look for a 4.4BSD-style sa_len member in struct sockaddr.
+diff -urN bind-9.3.1/configure.in bind-9.3.1.new/configure.in
+--- bind-9.3.1/configure.in    2004-12-09 05:07:10.000000000 +0100
++++ bind-9.3.1.new/configure.in        2006-07-31 14:16:55.000000000 +0200
+@@ -362,7 +362,7 @@
+                           (Required for DNSSEC)],
+     use_openssl="$withval", use_openssl="auto")
+-openssldirs="/usr /usr/local /usr/local/ssl /usr/pkg"
++openssldirs="$STAGING_DIR/usr/include $STAGING_DIR/include"
+ if test "$use_openssl" = "auto"
+ then
+       for d in $openssldirs
+diff -urN bind-9.3.1/configure bind-9.3.1.new/configure
+--- bind-9.3.1/lib/bind/configure      2004-12-09 05:09:03.000000000 +0100
++++ bind-9.3.1.new/lib/bind/configure  2006-07-31 14:24:19.000000000 +0200
+@@ -5289,6 +5289,7 @@
+ if eval "test \"\${$as_ac_File+set}\" = set"; then
+   echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
++cross_compiling=no
+   test "$cross_compiling" = yes &&
+   { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+ echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+
diff --git a/net/bind/patches/110-host_build_fix.patch b/net/bind/patches/110-host_build_fix.patch
new file mode 100644 (file)
index 0000000..0f330b1
--- /dev/null
@@ -0,0 +1,11 @@
+--- bind-9.3.1/lib/dns/Makefile.in.old Sun Oct 15 01:27:40 2006
++++ bind-9.3.1/lib/dns/Makefile.in     Sun Oct 15 01:28:15 2006
+@@ -156,7 +156,7 @@
+       ./gen -s ${srcdir} > code.h
+ gen: gen.c
+-      ${CC} ${ALL_CFLAGS} ${LDFLAGS} -o $@ ${srcdir}/gen.c ${LIBS}
++      ${CC} ${ALL_CFLAGS} -o $@ ${srcdir}/gen.c
+ rbtdb64.@O@: rbtdb.c
diff --git a/net/bind/patches/cross-compile.patch b/net/bind/patches/cross-compile.patch
deleted file mode 100644 (file)
index c8187c6..0000000
+++ /dev/null
@@ -1,220 +0,0 @@
-diff -urN bind-9.3.1/configure bind-9.3.1.new/configure
---- bind-9.3.1/configure       2004-12-09 05:09:03.000000000 +0100
-+++ bind-9.3.1.new/configure   2006-07-31 14:24:19.000000000 +0200
-@@ -4750,7 +4750,7 @@
-   use_openssl="auto"
- fi;
--openssldirs="/usr /usr/local /usr/local/ssl /usr/pkg"
-+openssldirs="-I$STAGING_DIR/usr/include"
- if test "$use_openssl" = "auto"
- then
-       for d in $openssldirs
-@@ -5289,6 +5289,7 @@
- if eval "test \"\${$as_ac_File+set}\" = set"; then
-   echo $ECHO_N "(cached) $ECHO_C" >&6
- else
-+cross_compiling=no
-   test "$cross_compiling" = yes &&
-   { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
- echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
-@@ -23675,175 +23676,6 @@
- # which provides some (all?) of the desired functions.
- #
--echo "$as_me:$LINENO: checking for inet_ntop with IPv6 support" >&5
--echo $ECHO_N "checking for inet_ntop with IPv6 support... $ECHO_C" >&6
--if test "$cross_compiling" = yes; then
--  { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
--See \`config.log' for more details." >&5
--echo "$as_me: error: cannot run test program while cross compiling
--See \`config.log' for more details." >&2;}
--   { (exit 1); exit 1; }; }
--else
--  cat >conftest.$ac_ext <<_ACEOF
--/* confdefs.h.  */
--_ACEOF
--cat confdefs.h >>conftest.$ac_ext
--cat >>conftest.$ac_ext <<_ACEOF
--/* end confdefs.h.  */
--
--#include <sys/types.h>
--#include <sys/socket.h>
--#include <netinet/in.h>
--#include <arpa/inet.h>
--main() {
--char a[16],b[64]; return(inet_ntop(AF_INET6, a, b, sizeof(b)) == (char*)0);}
--_ACEOF
--rm -f conftest$ac_exeext
--if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
--  (eval $ac_link) 2>&5
--  ac_status=$?
--  echo "$as_me:$LINENO: \$? = $ac_status" >&5
--  (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
--  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
--  (eval $ac_try) 2>&5
--  ac_status=$?
--  echo "$as_me:$LINENO: \$? = $ac_status" >&5
--  (exit $ac_status); }; }; then
--  echo "$as_me:$LINENO: result: yes" >&5
--echo "${ECHO_T}yes" >&6
--        ISC_PLATFORM_NEEDNTOP="#undef ISC_PLATFORM_NEEDNTOP"
--else
--  echo "$as_me: program exited with status $ac_status" >&5
--echo "$as_me: failed program was:" >&5
--sed 's/^/| /' conftest.$ac_ext >&5
--
--( exit $ac_status )
--echo "$as_me:$LINENO: result: no" >&5
--echo "${ECHO_T}no" >&6
--        ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_ntop.$O"
--        ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_ntop.c"
--        ISC_PLATFORM_NEEDNTOP="#define ISC_PLATFORM_NEEDNTOP 1"
--fi
--rm -f core *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
--fi
--
--
--# On NetBSD 1.4.2 and maybe others, inet_pton() incorrectly accepts
--# addresses with less than four octets, like "1.2.3".  Also leading
--# zeros should also be rejected.
--
--echo "$as_me:$LINENO: checking for working inet_pton with IPv6 support" >&5
--echo $ECHO_N "checking for working inet_pton with IPv6 support... $ECHO_C" >&6
--if test "$cross_compiling" = yes; then
--  echo "$as_me:$LINENO: result: assuming target platform has working inet_pton" >&5
--echo "${ECHO_T}assuming target platform has working inet_pton" >&6
--      ISC_PLATFORM_NEEDPTON="#undef ISC_PLATFORM_NEEDPTON"
--else
--  cat >conftest.$ac_ext <<_ACEOF
--/* confdefs.h.  */
--_ACEOF
--cat confdefs.h >>conftest.$ac_ext
--cat >>conftest.$ac_ext <<_ACEOF
--/* end confdefs.h.  */
--
--#include <sys/types.h>
--#include <sys/socket.h>
--#include <netinet/in.h>
--#include <arpa/inet.h>
--main() { char a[16]; return (inet_pton(AF_INET, "1.2.3", a) == 1 ? 1 :
--                           inet_pton(AF_INET, "1.2.3.04", a) == 1 ? 1 :
--                           (inet_pton(AF_INET6, "::1.2.3.4", a) != 1)); }
--_ACEOF
--rm -f conftest$ac_exeext
--if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
--  (eval $ac_link) 2>&5
--  ac_status=$?
--  echo "$as_me:$LINENO: \$? = $ac_status" >&5
--  (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
--  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
--  (eval $ac_try) 2>&5
--  ac_status=$?
--  echo "$as_me:$LINENO: \$? = $ac_status" >&5
--  (exit $ac_status); }; }; then
--  echo "$as_me:$LINENO: result: yes" >&5
--echo "${ECHO_T}yes" >&6
--        ISC_PLATFORM_NEEDPTON="#undef ISC_PLATFORM_NEEDPTON"
--else
--  echo "$as_me: program exited with status $ac_status" >&5
--echo "$as_me: failed program was:" >&5
--sed 's/^/| /' conftest.$ac_ext >&5
--
--( exit $ac_status )
--echo "$as_me:$LINENO: result: no" >&5
--echo "${ECHO_T}no" >&6
--        ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_pton.$O"
--        ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_pton.c"
--        ISC_PLATFORM_NEEDPTON="#define ISC_PLATFORM_NEEDPTON 1"
--fi
--rm -f core *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
--fi
--
--echo "$as_me:$LINENO: checking for inet_aton" >&5
--echo $ECHO_N "checking for inet_aton... $ECHO_C" >&6
--cat >conftest.$ac_ext <<_ACEOF
--/* confdefs.h.  */
--_ACEOF
--cat confdefs.h >>conftest.$ac_ext
--cat >>conftest.$ac_ext <<_ACEOF
--/* end confdefs.h.  */
--
--#include <sys/types.h>
--#include <netinet/in.h>
--#include <arpa/inet.h>
--int
--main ()
--{
--struct in_addr in; inet_aton(0, &in); return (0);
--  ;
--  return 0;
--}
--_ACEOF
--rm -f conftest.$ac_objext conftest$ac_exeext
--if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
--  (eval $ac_link) 2>conftest.er1
--  ac_status=$?
--  grep -v '^ *+' conftest.er1 >conftest.err
--  rm -f conftest.er1
--  cat conftest.err >&5
--  echo "$as_me:$LINENO: \$? = $ac_status" >&5
--  (exit $ac_status); } &&
--       { ac_try='test -z "$ac_c_werror_flag"
--                       || test ! -s conftest.err'
--  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
--  (eval $ac_try) 2>&5
--  ac_status=$?
--  echo "$as_me:$LINENO: \$? = $ac_status" >&5
--  (exit $ac_status); }; } &&
--       { ac_try='test -s conftest$ac_exeext'
--  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
--  (eval $ac_try) 2>&5
--  ac_status=$?
--  echo "$as_me:$LINENO: \$? = $ac_status" >&5
--  (exit $ac_status); }; }; then
--  echo "$as_me:$LINENO: result: yes" >&5
--echo "${ECHO_T}yes" >&6
--        ISC_PLATFORM_NEEDATON="#undef ISC_PLATFORM_NEEDATON"
--else
--  echo "$as_me: failed program was:" >&5
--sed 's/^/| /' conftest.$ac_ext >&5
--
--echo "$as_me:$LINENO: result: no" >&5
--echo "${ECHO_T}no" >&6
--        ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_aton.$O"
--        ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_aton.c"
--        ISC_PLATFORM_NEEDATON="#define ISC_PLATFORM_NEEDATON 1"
--fi
--rm -f conftest.err conftest.$ac_objext \
--      conftest$ac_exeext conftest.$ac_ext
--
--
--
--
- #
- # Look for a 4.4BSD-style sa_len member in struct sockaddr.
-diff -urN bind-9.3.1/configure.in bind-9.3.1.new/configure.in
---- bind-9.3.1/configure.in    2004-12-09 05:07:10.000000000 +0100
-+++ bind-9.3.1.new/configure.in        2006-07-31 14:16:55.000000000 +0200
-@@ -362,7 +362,7 @@
-                           (Required for DNSSEC)],
-     use_openssl="$withval", use_openssl="auto")
--openssldirs="/usr /usr/local /usr/local/ssl /usr/pkg"
-+openssldirs="$STAGING_DIR/usr/include $STAGING_DIR/include"
- if test "$use_openssl" = "auto"
- then
-       for d in $openssldirs
-diff -urN bind-9.3.1/configure bind-9.3.1.new/configure
---- bind-9.3.1/lib/bind/configure      2004-12-09 05:09:03.000000000 +0100
-+++ bind-9.3.1.new/lib/bind/configure  2006-07-31 14:24:19.000000000 +0200
-@@ -5289,6 +5289,7 @@
- if eval "test \"\${$as_ac_File+set}\" = set"; then
-   echo $ECHO_N "(cached) $ECHO_C" >&6
- else
-+cross_compiling=no
-   test "$cross_compiling" = yes &&
-   { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
- echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
-