octeon: fix imagebuilder
authorJohn Crispin <john@openwrt.org>
Fri, 29 May 2015 11:28:20 +0000 (11:28 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 29 May 2015 11:28:20 +0000 (11:28 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 45821

target/linux/octeon/image/Makefile

index a15e87b0c9516f6384e3b341551769e05a2e08a6..e74b06dd4b887461a15fe2f63422466ab2663592 100644 (file)
@@ -7,9 +7,13 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-define Image/BuildKernel/Template
+define Image/Prepare
        # Workaround pre-SDK-1.9.0 u-boot versions not handling the .notes section
-       $(TARGET_CROSS)strip -R .notes $(KDIR)/vmlinux.elf -o $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux.64
+       $(TARGET_CROSS)strip -R .notes $(KDIR)/vmlinux.elf -o $(KDIR)/vmlinux.elf.stripped
+endef
+
+define Image/BuildKernel/Template
+       $(CP) $(KDIR)/vmlinux.elf.stripped $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux.64
        $(STAGING_DIR_HOST)/bin/patch-cmdline $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux.64 '$(strip $(2))'
        md5sum $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux.64 | cut -d " " -f 1 | tee $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux.64.md5
 endef