[packages] add libotr package
authorPeter Wagner <​tripolar@gmx.at>
Wed, 30 Oct 2013 01:02:15 +0000 (01:02 +0000)
committerPeter Wagner <​tripolar@gmx.at>
Wed, 30 Oct 2013 01:02:15 +0000 (01:02 +0000)
Signed-off-by: Peter Wagner <tripolar@gmx.at>
SVN-Revision: 38580

libs/libotr/Makefile [new file with mode: 0644]

diff --git a/libs/libotr/Makefile b/libs/libotr/Makefile
new file mode 100644 (file)
index 0000000..bee6dab
--- /dev/null
@@ -0,0 +1,55 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libotr
+PKG_VERSION:=3.2.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.cypherpunks.ca/otr/
+PKG_MD5SUM:=974acf937d2ce0ee89b27a9815c17a3f
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libotr/Default
+  SECTION:=libs
+  CATEGORY:=Libraries
+  URL:=http://www.cypherpunks.ca/otr/
+endef
+
+define Package/libotr
+  $(call Package/libotr/Default)
+  DEPENDS:=+libgcrypt
+  TITLE:=OTR Messaging Library
+  MENU:=1
+endef
+
+define Package/libotr/description
+  Off-the-Record (OTR) Messaging allows you to have private conversations over
+  instant messaging.
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC='$(TARGET_CC) $(FPIC)' \
+               CFLAGS='$(TARGET_CFLAGS) -Wall -D_GNU_SOURCE' \
+               LDFLAGS='$(TARGET_LDFLAGS)' \
+               all
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/libotr $(1)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libotr.{a,la,so*} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libotr.pc $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libotr/install
+       $(INSTALL_DIR) $(1)/usr/lib $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libotr.so.* $(1)/usr/lib/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
+endef
+
+$(eval $(call BuildPackage,libotr))