packages/lcd4linux: don't use --as-needed LD flag
authorGabor Juhos <juhosg@openwrt.org>
Sun, 12 Aug 2012 08:13:19 +0000 (08:13 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 12 Aug 2012 08:13:19 +0000 (08:13 +0000)
It causes build error if a graphical driver is selected:
drv.o:(.got+0x0): multiple definition of `_GLOBAL_OFFSET_TABLE_'
collect2: ld returned 1 exit status
make[5]: *** [lcd4linux] Error 1

SVN-Revision: 33134

utils/lcd4linux/patches/120-remove-as-needed-linker-option.patch [new file with mode: 0644]

diff --git a/utils/lcd4linux/patches/120-remove-as-needed-linker-option.patch b/utils/lcd4linux/patches/120-remove-as-needed-linker-option.patch
new file mode 100644 (file)
index 0000000..b5e56fe
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -18,7 +18,7 @@ ACLOCAL_AMFLAGS=-I m4
+ # use this for lots of warnings
+ #AM_CFLAGS = -D_GNU_SOURCE -std=c99 -m64 -Wall -W -pedantic -Wno-variadic-macros -fno-strict-aliasing
+-lcd4linux_LDFLAGS ="-Wl,--as-needed"
++lcd4linux_LDFLAGS = 
+ lcd4linux_LDADD   = @DRIVERS@ @PLUGINS@ @DRVLIBS@ @PLUGINLIBS@
+ lcd4linux_DEPENDENCIES = @DRIVERS@ @PLUGINS@