port (lib)db to buildroot-ng
authorNicolas Thill <nico@openwrt.org>
Sat, 22 Jul 2006 16:08:55 +0000 (16:08 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 22 Jul 2006 16:08:55 +0000 (16:08 +0000)
SVN-Revision: 4211

libs/db/Makefile [new file with mode: 0644]

diff --git a/libs/db/Makefile b/libs/db/Makefile
new file mode 100644 (file)
index 0000000..9321041
--- /dev/null
@@ -0,0 +1,102 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=db
+PKG_VERSION:=4.2.52
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/db-$(PKG_VERSION)
+PKG_SOURCE:=db-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=ftp://ftp.sleepycat.com/releases/ \
+       http://downloads.sleepycat.com/
+PKG_MD5SUM:=8b5cff6eb83972afdd8e0b821703c33c
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libdb
+  SECTION:=libs
+  CATEGORY:=Libraries
+  DEPENDS:=+libxml2
+  TITLE:=Berkeley DB library
+  DESCRIPTION:=Berkeley DB library.
+  URL:=http://www.sleepycat.com/products/db.shtml
+endef
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR)/build_unix; rm -f config.cache; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               ../dist/configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_NLS) \
+                       $(DISABLE_LARGEFILE) \
+                       --enable-shared \
+                       --enable-static \
+                       --disable-java \
+                       --enable-cxx \
+                       --disable-posixmutexes \
+                       --disable-uimutexes \
+                       --disable-tcl \
+                       --disable-rpc \
+                       --enable-compat185 \
+                       --enable-debug \
+                       --enable-statistics \
+                       --enable-replication \
+                       --enable-cryptography \
+       );
+endef
+
+define Build/Compile
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR)/build_unix \
+               DESTDIR="$(PKG_INSTALL_DIR)" install
+endef
+
+define Package/libdb/install
+       install -m0755 -d $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdb-*.so $(1)/usr/lib/
+endef
+
+define Build/InstallDev
+       mkdir -p $(STAGING_DIR)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/db.h $(STAGING_DIR)/usr/include/
+       mkdir -p $(STAGING_DIR)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdb*.{a,so} $(STAGING_DIR)/usr/lib/
+endef
+
+define Build/UninstallDev
+       rm -rf \
+               $(STAGING_DIR)/usr/include/db.h \
+               $(STAGING_DIR)/usr/lib/libdb*.{a,so}
+endef
+
+$(eval $(call BuildPackage,libdb))