cwiid: pass our CFLAGS
authorFlorian Fainelli <florian@openwrt.org>
Mon, 17 Mar 2014 17:14:31 +0000 (17:14 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 17 Mar 2014 17:14:31 +0000 (17:14 +0000)
The Makefile logic in cwiid is slightly complicated, overriding CC
turned out to be a non-intrusive way to pass down our CFLAGS.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 39939

utils/cwiid/Makefile

index 4a79f9d6ea0019e71bab3f038f38b7213c69675e..91a03306629e7b15f221fe3763de5ac8e54b8a1b 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cwiid
 PKG_VERSION:=0.6.00
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://abstrakraft.org/cwiid/downloads/
@@ -69,8 +69,7 @@ endef
 
 define Build/Compile
        $(MAKE) -C "$(PKG_BUILD_DIR)" \
-               CC="$(TARGET_CC)" \
-               OFLAGS="$(TARGET_CFLAGS)" \
+               CC="$(TARGET_CC) $(TARGET_CFLAGS)" \
                CPPFLAGS="$(TARGET_CPPFLAGS)" \
                LDFLAGS="$(TARGET_LDFLAGS) -L../libcwiid/" \
                all