fix build in WhiteRussian SDK
authorNicolas Thill <nico@openwrt.org>
Thu, 27 Jul 2006 12:43:58 +0000 (12:43 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 27 Jul 2006 12:43:58 +0000 (12:43 +0000)
SVN-Revision: 4303

libs/net-snmp/Makefile
net/freeradius/Makefile

index 4cb66fce627db58695b0b8cab06e533678655cf1..1ac628f13f0ee3ebd65f8e81e697ff66c36215b1 100644 (file)
@@ -20,6 +20,81 @@ PKG_CAT:=zcat
 
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libnetsnmp
+  SECTION:=libs
+  CATEGORY:=Libraries
+  DEPENDS:=+libelf
+  TITLE:=Open source SNMP implementation (librairies)
+  DESCRIPTION:=Open source SNMP (Simple Network Management Protocol) implementation (libraries).\\\
+    Simple Network Management Protocol (SNMP) is a widely used \\\
+    protocol for monitoring the health and welfare of network \\\
+    equipment (eg. routers), computer equipment and even devices \\\
+    like UPSs. Net-SNMP is a suite of applications used to implement \\\
+    SNMP v1, SNMP v2c and SNMP v3 using both IPv4 and IPv6.\\\
+    \\\
+    This package contains shared libraries, needed by other programs.
+  URL:=http://www.net-snmp.org/
+endef
+
+define Package/snmp-utils
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libnetsnmp
+  TITLE:=Open source SNMP implementation (utilities)
+  DESCRIPTION:=Open source SNMP (Simple Network Management Protocol) implementation (utilities).\\\
+    Simple Network Management Protocol (SNMP) is a widely used \\\
+    protocol for monitoring the health and welfare of network \\\
+    equipment (eg. routers), computer equipment and even devices \\\
+    like UPSs. Net-SNMP is a suite of applications used to implement \\\
+    SNMP v1, SNMP v2c and SNMP v3 using both IPv4 and IPv6.\\\
+    \\\
+    This package contains SNMP client utilities.
+  URL:=http://www.net-snmp.org/
+endef
+
+define Package/snmpd
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libnetsnmp
+  TITLE:=Open source SNMP implementation (daemon)
+  DESCRIPTION:=Open source SNMP (Simple Network Management Protocol) implementation (daemon).\\\
+    Simple Network Management Protocol (SNMP) is a widely used \\\
+    protocol for monitoring the health and welfare of network \\\
+    equipment (eg. routers), computer equipment and even devices \\\
+    like UPSs. Net-SNMP is a suite of applications used to implement \\\
+    SNMP v1, SNMP v2c and SNMP v3 using both IPv4 and IPv6.\\\
+    \\\
+    This package contains the SNMP agent, dynamically linked.
+  URL:=http://www.net-snmp.org/
+endef
+
+define Package/snmpd/conffiles
+/etc/default/snmpd
+/etc/snmp/snmpd.conf
+endef
+
+define Package/snmpd-static
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=Open source SNMP implementation (daemon)
+  DESCRIPTION:=Open source SNMP (Simple Network Management Protocol) implementation (daemon).\\\
+    Simple Network Management Protocol (SNMP) is a widely used \\\
+    protocol for monitoring the health and welfare of network \\\
+    equipment (eg. routers), computer equipment and even devices \\\
+    like UPSs. Net-SNMP is a suite of applications used to implement \\\
+    SNMP v1, SNMP v2c and SNMP v3 using both IPv4 and IPv6.\\\
+    \\\
+    This package contains the SNMP agent, statically linked.
+  URL:=http://www.net-snmp.org/
+endef
+
+define Package/snmpd-static/conffiles
+/etc/default/snmpd
+/etc/snmp/snmpd.conf
+endef
+
 SNMP_MIB_MODULES_INCLUDED = \
        host/hr_device \
        host/hr_disk \
@@ -99,81 +174,6 @@ PKG_CONFIGURE_OPTIONS = \
        --without-rpm \
        --without-zlib \
 
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libnetsnmp
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS:=+libelf
-  TITLE:=Open source SNMP implementation (librairies)
-  DESCRIPTION:=Open source SNMP (Simple Network Management Protocol) implementation (libraries).\\\
-    Simple Network Management Protocol (SNMP) is a widely used \\\
-    protocol for monitoring the health and welfare of network \\\
-    equipment (eg. routers), computer equipment and even devices \\\
-    like UPSs. Net-SNMP is a suite of applications used to implement \\\
-    SNMP v1, SNMP v2c and SNMP v3 using both IPv4 and IPv6.\\\
-    \\\
-    This package contains shared libraries, needed by other programs.
-  URL:=http://www.net-snmp.org/
-endef
-
-define Package/snmp-utils
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS:=+libnetsnmp
-  TITLE:=Open source SNMP implementation (utilities)
-  DESCRIPTION:=Open source SNMP (Simple Network Management Protocol) implementation (utilities).\\\
-    Simple Network Management Protocol (SNMP) is a widely used \\\
-    protocol for monitoring the health and welfare of network \\\
-    equipment (eg. routers), computer equipment and even devices \\\
-    like UPSs. Net-SNMP is a suite of applications used to implement \\\
-    SNMP v1, SNMP v2c and SNMP v3 using both IPv4 and IPv6.\\\
-    \\\
-    This package contains SNMP client utilities.
-  URL:=http://www.net-snmp.org/
-endef
-
-define Package/snmpd
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS:=+libnetsnmp
-  TITLE:=Open source SNMP implementation (daemon)
-  DESCRIPTION:=Open source SNMP (Simple Network Management Protocol) implementation (daemon).\\\
-    Simple Network Management Protocol (SNMP) is a widely used \\\
-    protocol for monitoring the health and welfare of network \\\
-    equipment (eg. routers), computer equipment and even devices \\\
-    like UPSs. Net-SNMP is a suite of applications used to implement \\\
-    SNMP v1, SNMP v2c and SNMP v3 using both IPv4 and IPv6.\\\
-    \\\
-    This package contains the SNMP agent, dynamically linked.
-  URL:=http://www.net-snmp.org/
-endef
-
-define Package/snmpd/conffiles
-/etc/default/snmpd
-/etc/snmp/snmpd.conf
-endef
-
-define Package/snmpd-static
-  SECTION:=net
-  CATEGORY:=Network
-  TITLE:=Open source SNMP implementation (daemon)
-  DESCRIPTION:=Open source SNMP (Simple Network Management Protocol) implementation (daemon).\\\
-    Simple Network Management Protocol (SNMP) is a widely used \\\
-    protocol for monitoring the health and welfare of network \\\
-    equipment (eg. routers), computer equipment and even devices \\\
-    like UPSs. Net-SNMP is a suite of applications used to implement \\\
-    SNMP v1, SNMP v2c and SNMP v3 using both IPv4 and IPv6.\\\
-    \\\
-    This package contains the SNMP agent, statically linked.
-  URL:=http://www.net-snmp.org/
-endef
-
-define Package/snmpd-static/conffiles
-/etc/default/snmpd
-/etc/snmp/snmpd.conf
-endef
-
 define Build/Configure
        (cd $(PKG_BUILD_DIR); rm -f config.cache; \
                $(TARGET_CONFIGURE_OPTS) \
@@ -212,14 +212,14 @@ define Build/Compile
                INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
                all install
        ( cd $(PKG_INSTALL_DIR); mv ./usr/sbin/snmpd ./usr/sbin/snmpd-shared; )
-ifneq ($(CONFIG_PACKAGE_snmpd-static),)
+       #ifneq ($(CONFIG_PACKAGE_snmpd-static),)
        ( cd $(PKG_BUILD_DIR); rm -f agent/snmpd; )
        $(MAKE) -C $(PKG_BUILD_DIR) \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -static" \
                INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
                all install
        ( cd $(PKG_INSTALL_DIR); mv ./usr/sbin/snmpd ./usr/sbin/snmpd-static; )
-endif
+       #endif
 endef
 
 define Package/libnetsnmp/install
index 0d0e964f4c35aecd51410c93a430bc3f73cde3a1..0902664edda3450d14f1286b6305a580a18150e5 100644 (file)
@@ -22,70 +22,6 @@ PKG_CAT:=zcat
 
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-PKG_CONFIGURE_OPTIONS := \
-       --enable-shared \
-       --disable-static \
-       --disable-ltdl-install \
-       --with-ltdl-include="$(STAGING_DIR)/usr/include" \
-       --with-ltdl-lib="$(STAGING_DIR)/usr/lib" \
-       --with-openssl-includes="$(STAGING_DIR)/usr/include" \
-       --with-openssl-libraries="$(STAGING_DIR)/usr/lib" \
-       --enable-strict-dependencies \
-       --with-raddbdir=/etc/freeradius \
-       --without-edir \
-       --without-snmp \
-       --with-experimental-modules \
-       --without-rlm_attr-rewrite \
-       --without-rlm_checkval \
-       --without-rlm_counter \
-       --without-rlm_dbm \
-       --with-rlm_eap \
-       --without-rlm_eap_sim \
-       --without-rlm_example \
-       --without-rlm_ippool \
-       --without-rlm_krb5 \
-       --without-rlm_otp \
-       --without-rlm_pam \
-       --without-rlm_perl \
-       --without-rlm_python \
-       --without-rlm_radutmp \
-       --without-rlm_smb \
-       --with-rlm_sql \
-       --with-rlm_sqlcounter \
-       --without-rlm_sql_db2 \
-       --without-rlm_sql_freetds \
-       --without-rlm_sql_iodbc \
-       --without-rlm_sql_oracle \
-       --without-rlm_sql_sybase \
-       --without-rlm_sql_unixodbc \
-       --without-rlm_sql_log \
-       --without-rlm_unix \
-
-ifneq ($(CONFIG_PACKAGE_freeradius-mod-ldap),)
-PKG_CONFIGURE_LIBS += -lcrypto -lssl
-PKG_CONFIGURE_OPTIONS += \
-       --with-rlm_ldap-include-dir="$(STAGING_DIR)/usr/include" \
-       --with-rlm_ldap-lib-dir="$(STAGING_DIR)/usr/lib"
-else
-PKG_CONFIGURE_OPTIONS += --without-rlm_ldap
-endif
-ifneq ($(CONFIG_PACKAGE_freeradius-mod-sql-mysql),)
-PKG_CONFIGURE_LIBS += -lz
-PKG_CONFIGURE_OPTIONS += \
-       --with-mysql-include-dir="$(STAGING_DIR)/usr/include" \
-       --with-mysql-lib-dir="$(STAGING_DIR)/usr/lib/mysql" \
-       --without-threads
-else
-PKG_CONFIGURE_OPTIONS += --without-rlm_sql_mysql
-endif
-ifneq ($(CONFIG_PACKAGE_freeradius-mod-sql-pgsql),)
-PKG_CONFIGURE_OPTIONS += \
-       --with-rlm_sql_postgresql-include-dir="$(STAGING_DIR)/usr/include" \
-       --with-rlm_sql_postgresql-lib-dir="$(STAGING_DIR)/usr/lib"
-else
-PKG_CONFIGURE_OPTIONS += --without-rlm_sql_postgresql
-endif
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/freeradius
@@ -250,6 +186,82 @@ define Package/freeradius-utils
   TITLE:=Misc. client utilities
 endef
 
+PKG_CONFIGURE_OPTIONS := \
+       --enable-shared \
+       --disable-static \
+       --disable-ltdl-install \
+       --with-ltdl-include="$(STAGING_DIR)/usr/include" \
+       --with-ltdl-lib="$(STAGING_DIR)/usr/lib" \
+       --with-openssl-includes="$(STAGING_DIR)/usr/include" \
+       --with-openssl-libraries="$(STAGING_DIR)/usr/lib" \
+       --enable-strict-dependencies \
+       --with-raddbdir=/etc/freeradius \
+       --without-edir \
+       --without-snmp \
+       --with-experimental-modules \
+       --without-rlm_attr-rewrite \
+       --without-rlm_checkval \
+       --without-rlm_counter \
+       --without-rlm_dbm \
+       --with-rlm_eap \
+       --without-rlm_eap_sim \
+       --without-rlm_example \
+       --without-rlm_ippool \
+       --without-rlm_krb5 \
+       --without-rlm_otp \
+       --without-rlm_pam \
+       --without-rlm_perl \
+       --without-rlm_python \
+       --without-rlm_radutmp \
+       --without-rlm_smb \
+       --with-rlm_sql \
+       --with-rlm_sqlcounter \
+       --without-rlm_sql_db2 \
+       --without-rlm_sql_freetds \
+       --without-rlm_sql_iodbc \
+       --without-rlm_sql_oracle \
+       --without-rlm_sql_sybase \
+       --without-rlm_sql_unixodbc \
+       --without-rlm_sql_log \
+       --without-rlm_unix \
+
+ifeq ($(SDK),)
+  ifneq ($(CONFIG_PACKAGE_freeradius-mod-ldap),)
+    PKG_CONFIGURE_LIBS += -lcrypto -lssl
+    PKG_CONFIGURE_OPTIONS += \
+               --with-rlm_ldap-include-dir="$(STAGING_DIR)/usr/include" \
+               --with-rlm_ldap-lib-dir="$(STAGING_DIR)/usr/lib"
+  else
+    PKG_CONFIGURE_OPTIONS += --without-rlm_ldap
+  endif
+  ifneq ($(CONFIG_PACKAGE_freeradius-mod-sql-mysql),)
+    PKG_CONFIGURE_LIBS += -lz
+    PKG_CONFIGURE_OPTIONS += \
+               --with-mysql-include-dir="$(STAGING_DIR)/usr/include" \
+               --with-mysql-lib-dir="$(STAGING_DIR)/usr/lib/mysql" \
+               --without-threads
+  else
+    PKG_CONFIGURE_OPTIONS += --without-rlm_sql_mysql
+  endif
+  ifneq ($(CONFIG_PACKAGE_freeradius-mod-sql-pgsql),)
+    PKG_CONFIGURE_OPTIONS += \
+               --with-rlm_sql_postgresql-include-dir="$(STAGING_DIR)/usr/include" \
+               --with-rlm_sql_postgresql-lib-dir="$(STAGING_DIR)/usr/lib"
+  else
+    PKG_CONFIGURE_OPTIONS += --without-rlm_sql_postgresql
+  endif
+else
+  PKG_CONFIGURE_LIBS += -lcrypto -lssl -lz
+  PKG_CONFIGURE_OPTIONS += \
+               --with-rlm_ldap-include-dir="$(STAGING_DIR)/usr/include" \
+               --with-rlm_ldap-lib-dir="$(STAGING_DIR)/usr/lib" \
+               --with-mysql-include-dir="$(STAGING_DIR)/usr/include" \
+               --with-mysql-lib-dir="$(STAGING_DIR)/usr/lib/mysql" \
+               --without-threads \
+               --with-rlm_sql_postgresql-include-dir="$(STAGING_DIR)/usr/include" \
+               --with-rlm_sql_postgresql-lib-dir="$(STAGING_DIR)/usr/lib"
+endif
+
 define Build/Configure
        (cd $(PKG_BUILD_DIR); rm -f config.cache; \
                $(TARGET_CONFIGURE_OPTS) \