[packages] ekg: explicitely disable libbind & libgsm, use 'make install', cleanup
authorNicolas Thill <nico@openwrt.org>
Tue, 6 Oct 2009 15:14:00 +0000 (15:14 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 6 Oct 2009 15:14:00 +0000 (15:14 +0000)
SVN-Revision: 17955

net/ekg/Makefile

index 64423605959025ce7ad3fce52e3f58faba262788..ff15808b462b072eb0b14003272f9bfd69523048 100644 (file)
@@ -24,20 +24,30 @@ define Package/ekg
   DEPENDS:=+zlib +libncurses
 endef
 
-CONFIGURE_ARGS += \
+CONFIGURE_ARGS+= \
        --without-c99-vsnprintf \
-       --without-libungif \
+       --without-bind \
+       --without-libgsm \
        --without-libjpeg \
+       --without-libungif \
        --without-openssl \
        --disable-libgadu-openssl \
        --enable-ui-ncurses \
        --disable-ui-readline \
-       CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
-       CFLAGS_LIBGADU="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include"
+
+CONFIGURE_VARS+= \
+       CFLAGS="$$$$CFLAGS $(TARGET_CPPFLAGS)" \
+       CFLAGS_LIBGADU="$$$$CFLAGS $(TARGET_CPPFLAGS)" \
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
 
 define Package/ekg/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/src/ekg $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ekg $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,ekg))