brcm47xx-2.6 cleanup, fix the kernel config
authorFelix Fietkau <nbd@openwrt.org>
Sat, 26 May 2007 15:58:34 +0000 (15:58 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 26 May 2007 15:58:34 +0000 (15:58 +0000)
SVN-Revision: 7339

target/linux/brcm47xx-2.6/config/default
target/linux/brcm47xx-2.6/files/arch/mips/bcm947xx/irq.c
target/linux/brcm47xx-2.6/files/arch/mips/bcm947xx/prom.c
target/linux/brcm47xx-2.6/files/drivers/mtd/maps/bcm47xx-flash.c
target/linux/brcm47xx-2.6/patches/180-b44_timeout.patch [deleted file]
target/linux/brcm47xx-2.6/patches/180-cpu_fixes2.patch [deleted file]
target/linux/brcm47xx-2.6/profiles/WRTSL54GS.mk [deleted file]

index 353c9d8f7762aec59014cb2623cf333e33ab7822..243ceb80da3631aa8666d735e763d8ec4c64f5cc 100644 (file)
@@ -2,12 +2,15 @@ CONFIG_32BIT=y
 # CONFIG_64BIT is not set
 # CONFIG_64BIT_PHYS_ADDR is not set
 # CONFIG_8139TOO is not set
+# CONFIG_ARCH_HAS_ILOG2_U32 is not set
+# CONFIG_ARCH_HAS_ILOG2_U64 is not set
 # CONFIG_ARPD is not set
 # CONFIG_ATMEL is not set
 CONFIG_B44=y
 CONFIG_BASE_SMALL=0
 # CONFIG_BCM43XX is not set
 CONFIG_BCM947XX=y
+CONFIG_BITREVERSE=y
 # CONFIG_BONDING is not set
 # CONFIG_BRIDGE_NETFILTER is not set
 # CONFIG_BSD_DISKLABEL is not set
@@ -78,10 +81,15 @@ CONFIG_CRYPTO_MD5=m
 CONFIG_DMA_NEED_PCI_MAP_STATE=y
 CONFIG_DMA_NONCOHERENT=y
 # CONFIG_E100 is not set
-# CONFIG_FIRMWARE_EDID is not set
 CONFIG_FS_POSIX_ACL=y
 CONFIG_GENERIC_FIND_NEXT_BIT=y
+CONFIG_GENERIC_GPIO=y
+# CONFIG_GENERIC_HARDIRQS_NO__DO_IRQ is not set
 # CONFIG_GEN_RTC is not set
+CONFIG_HAS_IOMEM=y
+CONFIG_HAS_IOPORT=y
+CONFIG_HID=m
+# CONFIG_HID_DEBUG is not set
 CONFIG_HW_HAS_PCI=y
 CONFIG_HW_RANDOM=y
 CONFIG_HZ=250
@@ -106,21 +114,17 @@ CONFIG_INPUT=m
 CONFIG_IPW2200_QOS=y
 # CONFIG_IP_DCCP is not set
 # CONFIG_IP_NF_ARPTABLES is not set
-# CONFIG_IP_NF_CT_PROTO_SCTP is not set
 # CONFIG_IP_NF_MATCH_ADDRTYPE is not set
-# CONFIG_IP_NF_MATCH_HASHLIMIT is not set
 # CONFIG_IP_NF_TARGET_NETMAP is not set
 # CONFIG_IP_NF_TARGET_SAME is not set
 # CONFIG_IP_ROUTE_VERBOSE is not set
 CONFIG_IRQ_CPU=y
 CONFIG_JFFS2_FS_DEBUG=0
-# CONFIG_LAN_SAA9730 is not set
 # CONFIG_LIBCRC32C is not set
 # CONFIG_LLC2 is not set
 # CONFIG_MACH_DECSTATION is not set
 # CONFIG_MACH_JAZZ is not set
 # CONFIG_MACH_VR41XX is not set
-CONFIG_MINI_FO=y
 CONFIG_MIPS=y
 # CONFIG_MIPS_ATLAS is not set
 # CONFIG_MIPS_BOSPORUS is not set
@@ -155,6 +159,7 @@ CONFIG_MIPS_MT_DISABLED=y
 CONFIG_MTD=y
 # CONFIG_MTD_ABSENT is not set
 CONFIG_MTD_BCM47XX=y
+CONFIG_MTD_BLKDEVS=y
 CONFIG_MTD_BLOCK=y
 # CONFIG_MTD_BLOCK2MTD is not set
 CONFIG_MTD_CFI=y
@@ -196,7 +201,6 @@ CONFIG_MTD_PARTITIONS=y
 # CONFIG_MTD_REDBOOT_PARTS is not set
 # CONFIG_MTD_ROM is not set
 # CONFIG_MTD_SLRAM is not set
-CONFIG_MTD_SPLIT_ROOTFS=y
 # CONFIG_NATSEMI is not set
 # CONFIG_NE2K_PCI is not set
 # CONFIG_NETFILTER_XT_MATCH_COMMENT is not set
@@ -211,16 +215,28 @@ CONFIG_MTD_SPLIT_ROOTFS=y
 # CONFIG_NET_EMATCH is not set
 # CONFIG_NET_IPGRE_BROADCAST is not set
 # CONFIG_NET_PKTGEN is not set
+CONFIG_NET_SCH_FIFO=y
 # CONFIG_NET_SCH_NETEM is not set
 # CONFIG_NET_VENDOR_3COM is not set
+CONFIG_NF_CONNTRACK=y
+CONFIG_NF_CONNTRACK_MARK=y
+# CONFIG_NF_NAT_AMANDA is not set
+CONFIG_NF_NAT_FTP=m
+CONFIG_NF_NAT_H323=m
+CONFIG_NF_NAT_IRC=m
+CONFIG_NF_NAT_NEEDED=y
+# CONFIG_NF_NAT_PPTP is not set
+CONFIG_NF_NAT_SIP=m
+# CONFIG_NF_NAT_TFTP is not set
 # CONFIG_NTFS_FS is not set
 # CONFIG_PAGE_SIZE_16KB is not set
 CONFIG_PAGE_SIZE_4KB=y
 # CONFIG_PAGE_SIZE_64KB is not set
 # CONFIG_PAGE_SIZE_8KB is not set
 # CONFIG_PMC_YOSEMITE is not set
+# CONFIG_PNPACPI is not set
 # CONFIG_PNX8550_JBS is not set
-# CONFIG_PNX8550_V2PCI is not set
+# CONFIG_PNX8550_STB810 is not set
 # CONFIG_PPP_MULTILINK is not set
 # CONFIG_PPP_SYNC_TTY is not set
 # CONFIG_PROC_KCORE is not set
@@ -254,7 +270,7 @@ CONFIG_SSB_PCICORE_HOSTMODE=y
 CONFIG_SSB_PCIHOST=y
 CONFIG_SSB_SERIAL=y
 # CONFIG_SSB_SILENT is not set
-CONFIG_GENERIC_GPIO=y
+CONFIG_SYSVIPC_SYSCTL=y
 CONFIG_SYS_HAS_CPU_MIPS32_R1=y
 CONFIG_SYS_SUPPORTS_32BIT_KERNEL=y
 CONFIG_SYS_SUPPORTS_ARBIT_HZ=y
@@ -265,11 +281,15 @@ CONFIG_SYS_SUPPORTS_LITTLE_ENDIAN=y
 CONFIG_TRAD_SIGNALS=y
 # CONFIG_UNUSED_SYMBOLS is not set
 # CONFIG_USB_CATC is not set
+# CONFIG_USB_EHCI_BIG_ENDIAN_MMIO is not set
 CONFIG_USB_EHCI_HCD=m
 # CONFIG_USB_EHCI_ROOT_HUB_TT is not set
 CONFIG_USB_EHCI_SPLIT_ISO=y
 # CONFIG_USB_EHCI_TT_NEWSCHED is not set
+# CONFIG_USB_GTCO is not set
 # CONFIG_USB_KAWETH is not set
+# CONFIG_USB_OHCI_BIG_ENDIAN_DESC is not set
+# CONFIG_USB_OHCI_BIG_ENDIAN_MMIO is not set
 CONFIG_USB_OHCI_HCD=m
 # CONFIG_USB_PEGASUS is not set
 # CONFIG_USB_RTL8150 is not set
@@ -285,3 +305,5 @@ CONFIG_USB_OHCI_HCD=m
 CONFIG_USB_UHCI_HCD=m
 # CONFIG_VIA_RHINE is not set
 # CONFIG_WATCHDOG is not set
+CONFIG_ZONE_DMA=y
+CONFIG_ZONE_DMA_FLAG=1
index 8727a4f95631224f78fd50be48e1dab2fc1fa39c..56d4c84b7d54bc596a64ffe4bb6a29036e6b7fea 100644 (file)
@@ -59,5 +59,5 @@ void plat_irq_dispatch(void)
 
 void __init arch_init_irq(void)
 {
-       mips_cpu_irq_init(0);
+       mips_cpu_irq_init();
 }
index 235d45aaddf39d8b4438f0387e65deb086f0536e..41ea0870b79799c3bee02034f336e91dd9731542 100644 (file)
@@ -56,7 +56,6 @@ void __init prom_init(void)
        add_memory_region(0, mem, BOOT_MEM_RAM);
 }
 
-unsigned long __init prom_free_prom_memory(void)
+void __init prom_free_prom_memory(void)
 {
-       return 0;
 }
index 8d4ebe42d87b321c1ea2ca1f24f0fd050f0b3e08..5068af848f4f3147eee872d3f23bab2b6e4654dc 100644 (file)
@@ -40,6 +40,7 @@
 #include <linux/module.h>
 #include <linux/types.h>
 #include <linux/kernel.h>
+#include <linux/sched.h>
 #include <linux/wait.h>
 #include <linux/mtd/mtd.h>
 #include <linux/mtd/map.h>
diff --git a/target/linux/brcm47xx-2.6/patches/180-b44_timeout.patch b/target/linux/brcm47xx-2.6/patches/180-b44_timeout.patch
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/target/linux/brcm47xx-2.6/patches/180-cpu_fixes2.patch b/target/linux/brcm47xx-2.6/patches/180-cpu_fixes2.patch
deleted file mode 100644 (file)
index 89254c0..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
---- linux-2.6.21.1/arch/mips/bcm947xx/irq.c.orig       2007-05-18 21:27:17.000000000 +0100
-+++ linux-2.6.21.1/arch/mips/bcm947xx/irq.c    2007-05-24 23:25:38.000000000 +0100
-@@ -59,5 +59,5 @@
- void __init arch_init_irq(void)
- {
--      mips_cpu_irq_init(0);
-+      mips_cpu_irq_init();
- }
---- linux-2.6.21.1/arch/mips/bcm947xx/prom.c.orig      2007-05-18 21:27:17.000000000 +0100
-+++ linux-2.6.21.1/arch/mips/bcm947xx/prom.c   2007-05-24 23:46:06.000000000 +0100
-@@ -56,7 +56,6 @@
-       add_memory_region(0, mem, BOOT_MEM_RAM);
- }
--unsigned long __init prom_free_prom_memory(void)
-+void __init prom_free_prom_memory(void)
- {
--      return 0;
- }
---- linux-2.6.21.1/drivers/mtd/maps/bcm47xx-flash.c.orig       2007-05-18 21:27:17.000000000 +0100
-+++ linux-2.6.21.1/drivers/mtd/maps/bcm47xx-flash.c    2007-05-25 00:22:18.000000000 +0100
-@@ -40,6 +40,7 @@
- #include <linux/module.h>
- #include <linux/types.h>
- #include <linux/kernel.h>
-+#include <linux/sched.h>
- #include <linux/wait.h>
- #include <linux/mtd/mtd.h>
- #include <linux/mtd/map.h>
diff --git a/target/linux/brcm47xx-2.6/profiles/WRTSL54GS.mk b/target/linux/brcm47xx-2.6/profiles/WRTSL54GS.mk
deleted file mode 100644 (file)
index 969160c..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/WRTSL54GS
-  NAME:=Linksys WRTSL54GS
-  PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage kmod-fs-ext3 e2fsprogs
-endef
-
-define Profile/WRTSL54GS/Description
-       Package set compatible with the Linksys WRTSL54GS. Contains USB support
-endef
-$(eval $(call Profile,WRTSL54GS))
-