[package] update libiksemel to 1.4 (#6250)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 29 Nov 2009 22:06:46 +0000 (22:06 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 29 Nov 2009 22:06:46 +0000 (22:06 +0000)
SVN-Revision: 18607

libs/iksemel/Makefile

index deaecaacea617b693f5ac670df7ded854473608c..08dc7cb668a98b5bc01a7255ce95be5575f8c216 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iksemel
-PKG_VERSION:=1.3
+PKG_VERSION:=1.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://iksemel.googlecode.com/files/
-PKG_MD5SUM:=36ab2d9f11980a19217b6f79a19ef8e7
+PKG_MD5SUM:=532e77181694f87ad5eb59435d11c1ca
 
 PKG_FIXUP = libtool
 
@@ -27,6 +27,13 @@ define Package/libiksemel
   DEPENDS:= +libgnutls +libtasn1
 endef
 
+define Package/libiksemel/description
+  Iksemel is an XML parser library mainly designed for Jabber applications.
+  It provides SAX, DOM, and special Jabber stream APIs. Library is coded
+  in ANSI C except the network code (which is POSIX compatible), thus
+  highly portable.
+endef
+
 TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS += \