[tools] mkimage: update to 2013.07-rc1
authorLuka Perkov <luka@openwrt.org>
Mon, 15 Jul 2013 23:18:36 +0000 (23:18 +0000)
committerLuka Perkov <luka@openwrt.org>
Mon, 15 Jul 2013 23:18:36 +0000 (23:18 +0000)
also remove 100-dtc-binary.patch which was not accepted upstream

Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 37361

tools/mkimage/Makefile
tools/mkimage/patches/010-freebsd-ulong-fix.patch
tools/mkimage/patches/020-openbsd_fixes.patch
tools/mkimage/patches/030-allow-to-use-different-magic.patch
tools/mkimage/patches/040-include_order.patch
tools/mkimage/patches/050-image_h_portability.patch
tools/mkimage/patches/100-dtc-binary.patch [deleted file]

index 458cca8fe527a9106b755ece385d46ef414879ab..fd06c721e8f6bbba30d3373e5a0b7d9057f4d3f6 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mkimage
-PKG_VERSION:=2013.04
+PKG_VERSION:=2013.07-rc1
 
 PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
index 715755b875c901d3c3f15c32714c8271d67c141c..b4951b0e25331ed0b1337ef3b5fc8e49ef685550 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/image.h
 +++ b/include/image.h
-@@ -51,6 +51,10 @@
+@@ -61,6 +61,10 @@
  
  #endif /* USE_HOSTCC */
  
index 4c376caadd6ac20a248c58600fd1acb9738592ff..17232360d2c2594f89bd2da453041b0f7f616560 100644 (file)
@@ -1,6 +1,6 @@
 --- a/tools/mkimage.c
 +++ b/tools/mkimage.c
-@@ -464,6 +464,7 @@ NXTARG:            ;
+@@ -464,6 +464,7 @@
  #if defined(_POSIX_SYNCHRONIZED_IO) && \
     !defined(__sun__) && \
     !defined(__FreeBSD__) && \
@@ -8,7 +8,7 @@
     !defined(__APPLE__)
        (void) fdatasync (ifd);
  #else
-@@ -507,6 +508,7 @@ NXTARG:            ;
+@@ -507,6 +508,7 @@
  #if defined(_POSIX_SYNCHRONIZED_IO) && \
     !defined(__sun__) && \
     !defined(__FreeBSD__) && \
index 14397964b6d86904d074c1e2c522463eb6243adb..afc3f21a81e64d8ede42ec1d3497584e75b61337 100644 (file)
@@ -1,6 +1,6 @@
 --- a/tools/mkimage.c
 +++ b/tools/mkimage.c
-@@ -37,6 +37,7 @@ struct mkimage_params params = {
+@@ -37,6 +37,7 @@
        .arch = IH_ARCH_PPC,
        .type = IH_TYPE_KERNEL,
        .comp = IH_COMP_GZIP,
@@ -8,7 +8,7 @@
        .dtc = MKIMAGE_DEFAULT_DTC_OPTIONS,
        .imagename = "",
        .imagename2 = "",
-@@ -189,6 +190,16 @@ main (int argc, char **argv)
+@@ -189,6 +190,16 @@
                                        genimg_get_comp_id (*++argv)) < 0)
                                        usage ();
                                goto NXTARG;
@@ -25,7 +25,7 @@
                        case 'D':
                                if (--argc <= 0)
                                        usage ();
-@@ -613,12 +624,13 @@ usage ()
+@@ -613,12 +624,13 @@
        fprintf (stderr, "Usage: %s -l image\n"
                         "          -l ==> list image header information\n",
                params.cmdname);
@@ -42,7 +42,7 @@
                         "          -n ==> set image name to 'name'\n"
 --- a/tools/mkimage.h
 +++ b/tools/mkimage.h
-@@ -65,6 +65,7 @@ struct mkimage_params {
+@@ -79,6 +79,7 @@
        int arch;
        int type;
        int comp;
@@ -52,7 +52,7 @@
        unsigned int ep;
 --- a/tools/default_image.c
 +++ b/tools/default_image.c
-@@ -111,7 +111,7 @@ static void image_set_header(void *ptr,
+@@ -111,7 +111,7 @@
                        sbuf->st_size - sizeof(image_header_t));
  
        /* Build new header */
index 94324666f461b130c5ed8c6e1e984e713d5214e0..e4dc78ef27427e6b601a5891909079cd784c4524 100644 (file)
@@ -1,6 +1,6 @@
 --- a/tools/Makefile
 +++ b/tools/Makefile
-@@ -165,9 +165,9 @@ NOPEDOBJS := $(addprefix $(obj),$(NOPED_
+@@ -160,9 +160,9 @@
  # Define __KERNEL_STRICT_NAMES to prevent typedef overlaps
  #
  HOSTCPPFLAGS =        -include $(SRCTREE)/include/libfdt_env.h \
index 1f222370bce4eabeb634edfa02b0c0390fa1ea78..86d5226982b860d66a91503784620559f8e5cb49 100644 (file)
@@ -6,9 +6,9 @@
  #include "compiler.h"
 -#include <asm/byteorder.h>
  
- #ifdef USE_HOSTCC
-@@ -191,13 +190,13 @@
+ /* Define this to avoid #ifdefs later on */
+ struct lmb;
+@@ -254,13 +253,13 @@
   * all data in network byte order (aka natural aka bigendian).
   */
  typedef struct image_header {
diff --git a/tools/mkimage/patches/100-dtc-binary.patch b/tools/mkimage/patches/100-dtc-binary.patch
deleted file mode 100644 (file)
index 5034119..0000000
+++ /dev/null
@@ -1,86 +0,0 @@
---- a/doc/mkimage.1
-+++ b/doc/mkimage.1
-@@ -82,6 +82,10 @@
- .B Create FIT image:
- .TP
-+.BI "\-B [" "dtc bin" "]"
-+Set path to the device tree compiler binary.
-+
-+.TP
- .BI "\-D [" "dtc options" "]"
- Provide special options to the device tree compiler that is used to
- create the image.
---- a/tools/fit_image.c
-+++ b/tools/fit_image.c
-@@ -82,7 +82,8 @@
-       /* dtc -I dts -O dtb -p 500 datafile > tmpfile */
-       sprintf (cmd, "%s %s %s > %s",
--              MKIMAGE_DTC, params->dtc, params->datafile, tmpfile);
-+              params->dtc_bin, params->dtc_options, params->datafile,
-+              tmpfile);
-       debug ("Trying to execute \"%s\"\n", cmd);
-       if (system (cmd) == -1) {
-               fprintf (stderr, "%s: system(%s) failed: %s\n",
---- a/tools/mkimage.c
-+++ b/tools/mkimage.c
-@@ -38,7 +38,8 @@
-       .type = IH_TYPE_KERNEL,
-       .comp = IH_COMP_GZIP,
-       .magic = IH_MAGIC,
--      .dtc = MKIMAGE_DEFAULT_DTC_OPTIONS,
-+      .dtc_bin = MKIMAGE_DTC,
-+      .dtc_options = MKIMAGE_DEFAULT_DTC_OPTIONS,
-       .imagename = "",
-       .imagename2 = "",
- };
-@@ -200,10 +201,15 @@
-                                               params.cmdname, *argv);
-                               }
-                               goto NXTARG;
-+                      case 'B':
-+                              if (--argc <= 0)
-+                                      usage ();
-+                              params.dtc_bin = *++argv;
-+                              goto NXTARG;
-                       case 'D':
-                               if (--argc <= 0)
-                                       usage ();
--                              params.dtc = *++argv;
-+                              params.dtc_options = *++argv;
-                               goto NXTARG;
-                       case 'O':
-@@ -637,7 +643,9 @@
-                        "          -d ==> use image data from 'datafile'\n"
-                        "          -x ==> set XIP (execute in place)\n",
-               params.cmdname);
--      fprintf (stderr, "       %s [-D dtc_options] -f fit-image.its fit-image\n",
-+      fprintf (stderr, "       %s [-B dtc_bin] [-D dtc_options] -f fit-image.its fit-image\n",
-+                       "           -B ==> set path to the dtc binary\n",
-+                       "           -D ==> set options that will be passed to dtc\n",
-               params.cmdname);
-       fprintf (stderr, "       %s -V ==> print version information and exit\n",
-               params.cmdname);
---- a/tools/mkimage.h
-+++ b/tools/mkimage.h
-@@ -46,7 +46,7 @@
- #define MKIMAGE_MAX_TMPFILE_LEN               256
- #define MKIMAGE_DEFAULT_DTC_OPTIONS   "-I dts -O dtb -p 500"
- #define MKIMAGE_MAX_DTC_CMDLINE_LEN   512
--#define MKIMAGE_DTC                   "dtc"   /* assume dtc is in $PATH */
-+#define MKIMAGE_DTC                   "dtc"
- /*
-  * This structure defines all such variables those are initialized by
-@@ -66,7 +66,8 @@
-       int type;
-       int comp;
-       unsigned int magic;
--      char *dtc;
-+      char *dtc_bin;
-+      char *dtc_options;
-       unsigned int addr;
-       unsigned int ep;
-       char *imagename;