ar71xx: add driver for the USB LED on the WNDR3700
authorGabor Juhos <juhosg@openwrt.org>
Fri, 11 Dec 2009 20:32:31 +0000 (20:32 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 11 Dec 2009 20:32:31 +0000 (20:32 +0000)
SVN-Revision: 18758

target/linux/ar71xx/config-2.6.30
target/linux/ar71xx/config-2.6.31
target/linux/ar71xx/config-2.6.32
target/linux/ar71xx/files/arch/mips/ar71xx/mach-wndr3700.c
target/linux/ar71xx/files/drivers/leds/leds-wndr3700-usb.c [new file with mode: 0644]
target/linux/ar71xx/patches-2.6.30/205-wndr3700-usb-led-driver.patch [new file with mode: 0644]
target/linux/ar71xx/patches-2.6.31/205-wndr3700-usb-led-driver.patch [new file with mode: 0644]
target/linux/ar71xx/patches-2.6.32/205-wndr3700-usb-led-driver.patch [new file with mode: 0644]

index 9b7e5fe953e63273bdae8e7d2e9e4bc3fc4b6fa1..66b1b8fb34fa80e830ebd1c0d30b24a3ee266cbb 100644 (file)
@@ -113,6 +113,7 @@ CONFIG_INITRAMFS_SOURCE="../../root"
 CONFIG_IRQ_CPU=y
 # CONFIG_ISDN is not set
 # CONFIG_LEDS_GPIO is not set
+# CONFIG_LEDS_WNDR3700_USB is not set
 # CONFIG_LEMOTE_FULONG is not set
 # CONFIG_M25PXX_USE_FAST_READ is not set
 # CONFIG_MACH_ALCHEMY is not set
index a975cd7a54ed8b5a9d76e2ad954248c9067096b9..b699e4b81a1ad97ee9cf754bd3eb1a46838ec653 100644 (file)
@@ -116,6 +116,7 @@ CONFIG_INITRAMFS_SOURCE="../../root"
 CONFIG_IRQ_CPU=y
 # CONFIG_ISDN is not set
 # CONFIG_LEDS_GPIO is not set
+# CONFIG_LEDS_WNDR3700_USB is not set
 # CONFIG_LEMOTE_FULONG is not set
 # CONFIG_M25PXX_USE_FAST_READ is not set
 CONFIG_MAC80211_DEFAULT_PS_VALUE=0
index 671002f8dd75e7b26c044796793c03506f362f77..cedfa8e72faab6fce4891d1bb1cff69002d915b1 100644 (file)
@@ -118,6 +118,7 @@ CONFIG_INITRAMFS_SOURCE="../../root"
 CONFIG_IRQ_CPU=y
 # CONFIG_ISDN is not set
 # CONFIG_LEDS_GPIO is not set
+# CONFIG_LEDS_WNDR3700_USB is not set
 # CONFIG_M25PXX_USE_FAST_READ is not set
 # CONFIG_MACH_ALCHEMY is not set
 # CONFIG_MACH_DECSTATION is not set
index 25b5fc06247ac9c449df1650c6ffd77a0c69f0f2..729267ac461488bd668dea8db83cd3bd623b9e83 100644 (file)
@@ -325,6 +325,7 @@ static void __init wndr3700_setup(void)
                                      wndr3700_gpio_buttons);
 
        platform_device_register(&wndr3700_rtl8366_smi_device);
+       platform_device_register_simple("wndr3700-led-usb", -1, NULL, 0);
        wndr3700_pci_init();
 }
 
diff --git a/target/linux/ar71xx/files/drivers/leds/leds-wndr3700-usb.c b/target/linux/ar71xx/files/drivers/leds/leds-wndr3700-usb.c
new file mode 100644 (file)
index 0000000..9f17861
--- /dev/null
@@ -0,0 +1,75 @@
+/*
+ *  USB LED driver for the NETGEAR WNDR3700
+ *
+ *  Copyright (C) 2009 Gabor Juhos <juhosg@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/leds.h>
+#include <linux/module.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ar71xx/ar71xx.h>
+
+#define DRIVER_NAME    "wndr3700-led-usb"
+
+static void wndr3700_usb_led_set(struct led_classdev *cdev,
+                                enum led_brightness brightness)
+{
+       if (brightness)
+               ar71xx_device_start(RESET_MODULE_GE1_PHY);
+       else
+               ar71xx_device_stop(RESET_MODULE_GE1_PHY);
+}
+
+static enum led_brightness wndr3700_usb_led_get(struct led_classdev *cdev)
+{
+       return ar71xx_device_stopped(RESET_MODULE_GE1_PHY) ? LED_OFF : LED_FULL;
+}
+
+static struct led_classdev wndr3700_usb_led = {
+       .name = "wndr3700:green:usb",
+       .brightness_set = wndr3700_usb_led_set,
+       .brightness_get = wndr3700_usb_led_get,
+};
+
+static int __devinit wndr3700_usb_led_probe(struct platform_device *pdev)
+{
+       return led_classdev_register(&pdev->dev, &wndr3700_usb_led);
+}
+
+static int __devexit wndr3700_usb_led_remove(struct platform_device *pdev)
+{
+       led_classdev_unregister(&wndr3700_usb_led);
+       return 0;
+}
+
+static struct platform_driver wndr3700_usb_led_driver = {
+       .probe = wndr3700_usb_led_probe,
+       .remove = __devexit_p(wndr3700_usb_led_remove),
+       .driver = {
+               .name = DRIVER_NAME,
+               .owner = THIS_MODULE,
+       },
+};
+
+static int __init wndr3700_usb_led_init(void)
+{
+       return platform_driver_register(&wndr3700_usb_led_driver);
+}
+
+static void __exit wndr3700_usb_led_exit(void)
+{
+       platform_driver_unregister(&wndr3700_usb_led_driver);
+}
+
+module_init(wndr3700_usb_led_init);
+module_exit(wndr3700_usb_led_exit);
+
+MODULE_DESCRIPTION("USB LED driver for the NETGEAR WNDR3700");
+MODULE_AUTHOR("Gabor Juhos <juhosg@openwrt.org>");
+MODULE_LICENSE("GPL v2");
+MODULE_ALIAS("platform:" DRIVER_NAME);
diff --git a/target/linux/ar71xx/patches-2.6.30/205-wndr3700-usb-led-driver.patch b/target/linux/ar71xx/patches-2.6.30/205-wndr3700-usb-led-driver.patch
new file mode 100644 (file)
index 0000000..53ece92
--- /dev/null
@@ -0,0 +1,26 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -227,6 +227,13 @@
+         This option enables support for BD2802GU RGB LED driver chips
+         accessed via the I2C bus.
++config LEDS_WNDR3700_USB
++      tristate "NETGEAR WNDR3700 USB LED driver"
++      depends on LEDS_CLASS && AR71XX_MACH_WNDR3700
++      help
++        This option enables support for the USB LED found on the
++        NETGEAR WNDR3700 board.
++
+ comment "LED Triggers"
+ config LEDS_TRIGGERS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -27,6 +27,7 @@
+ obj-$(CONFIG_LEDS_DA903X)             += leds-da903x.o
+ obj-$(CONFIG_LEDS_WM8350)             += leds-wm8350.o
+ obj-$(CONFIG_LEDS_PWM)                        += leds-pwm.o
++obj-${CONFIG_LEDS_WNDR3700_USB}               += leds-wndr3700-usb.o
+ # LED SPI Drivers
+ obj-$(CONFIG_LEDS_DAC124S085)         += leds-dac124s085.o
diff --git a/target/linux/ar71xx/patches-2.6.31/205-wndr3700-usb-led-driver.patch b/target/linux/ar71xx/patches-2.6.31/205-wndr3700-usb-led-driver.patch
new file mode 100644 (file)
index 0000000..d9fba35
--- /dev/null
@@ -0,0 +1,26 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -229,6 +229,13 @@ config LEDS_BD2802
+         This option enables support for BD2802GU RGB LED driver chips
+         accessed via the I2C bus.
++config LEDS_WNDR3700_USB
++      tristate "NETGEAR WNDR3700 USB LED driver"
++      depends on LEDS_CLASS && AR71XX_MACH_WNDR3700
++      help
++        This option enables support for the USB LED found on the
++        NETGEAR WNDR3700 board.
++
+ comment "LED Triggers"
+ config LEDS_TRIGGERS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -28,6 +28,7 @@ obj-$(CONFIG_LEDS_PCA955X)           += leds-pca9
+ obj-$(CONFIG_LEDS_DA903X)             += leds-da903x.o
+ obj-$(CONFIG_LEDS_WM8350)             += leds-wm8350.o
+ obj-$(CONFIG_LEDS_PWM)                        += leds-pwm.o
++obj-${CONFIG_LEDS_WNDR3700_USB}               += leds-wndr3700-usb.o
+ # LED SPI Drivers
+ obj-$(CONFIG_LEDS_DAC124S085)         += leds-dac124s085.o
diff --git a/target/linux/ar71xx/patches-2.6.32/205-wndr3700-usb-led-driver.patch b/target/linux/ar71xx/patches-2.6.32/205-wndr3700-usb-led-driver.patch
new file mode 100644 (file)
index 0000000..3f7c848
--- /dev/null
@@ -0,0 +1,26 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -236,6 +236,13 @@ config LEDS_BD2802
+         This option enables support for BD2802GU RGB LED driver chips
+         accessed via the I2C bus.
++config LEDS_WNDR3700_USB
++      tristate "NETGEAR WNDR3700 USB LED driver"
++      depends on LEDS_CLASS && AR71XX_MACH_WNDR3700
++      help
++        This option enables support for the USB LED found on the
++        NETGEAR WNDR3700 board.
++
+ comment "LED Triggers"
+ config LEDS_TRIGGERS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -29,6 +29,7 @@ obj-$(CONFIG_LEDS_DA903X)            += leds-da903
+ obj-$(CONFIG_LEDS_WM831X_STATUS)      += leds-wm831x-status.o
+ obj-$(CONFIG_LEDS_WM8350)             += leds-wm8350.o
+ obj-$(CONFIG_LEDS_PWM)                        += leds-pwm.o
++obj-${CONFIG_LEDS_WNDR3700_USB}               += leds-wndr3700-usb.o
+ # LED SPI Drivers
+ obj-$(CONFIG_LEDS_DAC124S085)         += leds-dac124s085.o