ar71xx: refresh kernel patches
authorGabor Juhos <juhosg@openwrt.org>
Sat, 8 Sep 2012 13:39:04 +0000 (13:39 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 8 Sep 2012 13:39:04 +0000 (13:39 +0000)
SVN-Revision: 33334

target/linux/ar71xx/patches-3.3/406-mtd-m25p80-allow-to-specify-max-read-size.patch
target/linux/ar71xx/patches-3.3/407-mtd-m25p80-allow-to-pass-probe-types-via-platform-data.patch
target/linux/ar71xx/patches-3.3/412-mtd-m25p80-zero-partition-parser-data.patch
target/linux/ar71xx/patches-3.3/430-drivers-link-spi-before-mtd.patch
target/linux/ar71xx/patches-3.3/610-MIPS-ath79-openwrt-machines.patch
target/linux/ar71xx/patches-3.3/612-ALL0315N-support.patch

index 86d9535802d9ee2297d177f67fe94cb83bd34e1c..8861c615fa613caea0c44628d131aa78fdc7512a 100644 (file)
@@ -87,7 +87,7 @@
  
        mutex_unlock(&flash->lock);
  
  
        mutex_unlock(&flash->lock);
  
-@@ -924,6 +950,12 @@ static int __devinit m25p_probe(struct s
+@@ -925,6 +951,12 @@ static int __devinit m25p_probe(struct s
        flash->mtd.erase = m25p80_erase;
        flash->mtd.read = m25p80_read;
  
        flash->mtd.erase = m25p80_erase;
        flash->mtd.read = m25p80_read;
  
index fd78019104cfda23f0e5ceb8dd8c443a621bea6a..14f2de536c11120e02ce7110b5dd7b4a14d8afa8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/devices/m25p80.c
 +++ b/drivers/mtd/devices/m25p80.c
 --- a/drivers/mtd/devices/m25p80.c
 +++ b/drivers/mtd/devices/m25p80.c
-@@ -1017,7 +1017,9 @@ static int __devinit m25p_probe(struct s
+@@ -1018,7 +1018,9 @@ static int __devinit m25p_probe(struct s
        /* partitions should match sector boundaries; and it may be good to
         * use readonly partitions for writeprotected sectors (BP2..BP0).
         */
        /* partitions should match sector boundaries; and it may be good to
         * use readonly partitions for writeprotected sectors (BP2..BP0).
         */
index a32a19629cfc25211761ea6949f857bfaea172f7..a667139d0119721ec3672d991e56abb832e6f4d2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/devices/m25p80.c
 +++ b/drivers/mtd/devices/m25p80.c
 --- a/drivers/mtd/devices/m25p80.c
 +++ b/drivers/mtd/devices/m25p80.c
-@@ -977,6 +977,7 @@ static int __devinit m25p_probe(struct s
+@@ -978,6 +978,7 @@ static int __devinit m25p_probe(struct s
        if (info->flags & M25P_NO_ERASE)
                flash->mtd.flags |= MTD_NO_ERASE;
  
        if (info->flags & M25P_NO_ERASE)
                flash->mtd.flags |= MTD_NO_ERASE;
  
index e081087f2f8e87d1e380c780bc23bbc8869fe497..f54861be6caf5cb69f45195debbb02f2170c06b9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/Makefile
 +++ b/drivers/Makefile
 --- a/drivers/Makefile
 +++ b/drivers/Makefile
-@@ -51,8 +51,8 @@ obj-$(CONFIG_IDE)            += ide/
+@@ -52,8 +52,8 @@ obj-$(CONFIG_IDE)            += ide/
  obj-$(CONFIG_SCSI)            += scsi/
  obj-$(CONFIG_ATA)             += ata/
  obj-$(CONFIG_TARGET_CORE)     += target/
  obj-$(CONFIG_SCSI)            += scsi/
  obj-$(CONFIG_ATA)             += ata/
  obj-$(CONFIG_TARGET_CORE)     += target/
index 34965dcda8537deaeb9370dea3b428ed56361c8e..10fefd067eaddbb42b949aabbd4c2485772a406c 100644 (file)
  endif
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
  endif
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -36,9 +36,62 @@ obj-$(CONFIG_ATH79_PCI_ATH9K_FIXUP) += pci-ath9k-fixup.o
+@@ -36,9 +36,62 @@ obj-$(CONFIG_ATH79_PCI_ATH9K_FIXUP) += p
  #
  # Machines
  #
  #
  # Machines
  #
index 9c054da5b43bf85d133a933b0f521f793d6a426c..bc4e6695e812f0c64a2dc20794bc318ba57767b1 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-3.3.8/arch/mips/ath79/Kconfig
-===================================================================
---- linux-3.3.8.orig/arch/mips/ath79/Kconfig
-+++ linux-3.3.8/arch/mips/ath79/Kconfig
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
 @@ -38,6 +38,15 @@ config ATH79_MACH_ALL0258N
        select ATH79_DEV_LEDS_GPIO
        select ATH79_DEV_M25P80
 @@ -38,6 +38,15 @@ config ATH79_MACH_ALL0258N
        select ATH79_DEV_LEDS_GPIO
        select ATH79_DEV_M25P80
@@ -18,10 +16,8 @@ Index: linux-3.3.8/arch/mips/ath79/Kconfig
  config ATH79_MACH_AP113
        bool "Atheros AP113 board support"
        select SOC_AR724X
  config ATH79_MACH_AP113
        bool "Atheros AP113 board support"
        select SOC_AR724X
-Index: linux-3.3.8/arch/mips/ath79/Makefile
-===================================================================
---- linux-3.3.8.orig/arch/mips/ath79/Makefile
-+++ linux-3.3.8/arch/mips/ath79/Makefile
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
 @@ -39,6 +39,7 @@ obj-$(CONFIG_ATH79_PCI_ATH9K_FIXUP)  += p
  obj-$(CONFIG_ATH79_MACH_ALFA_AP96)    += mach-alfa-ap96.o
  obj-$(CONFIG_ATH79_MACH_ALFA_NX)      += mach-alfa-nx.o
 @@ -39,6 +39,7 @@ obj-$(CONFIG_ATH79_PCI_ATH9K_FIXUP)  += p
  obj-$(CONFIG_ATH79_MACH_ALFA_AP96)    += mach-alfa-ap96.o
  obj-$(CONFIG_ATH79_MACH_ALFA_NX)      += mach-alfa-nx.o
@@ -30,10 +26,8 @@ Index: linux-3.3.8/arch/mips/ath79/Makefile
  obj-$(CONFIG_ATH79_MACH_AP113)                += mach-ap113.o
  obj-$(CONFIG_ATH79_MACH_AP121)                += mach-ap121.o
  obj-$(CONFIG_ATH79_MACH_AP136)                += mach-ap136.o
  obj-$(CONFIG_ATH79_MACH_AP113)                += mach-ap113.o
  obj-$(CONFIG_ATH79_MACH_AP121)                += mach-ap121.o
  obj-$(CONFIG_ATH79_MACH_AP136)                += mach-ap136.o
-Index: linux-3.3.8/arch/mips/ath79/machtypes.h
-===================================================================
---- linux-3.3.8.orig/arch/mips/ath79/machtypes.h
-+++ linux-3.3.8/arch/mips/ath79/machtypes.h
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
 @@ -20,6 +20,7 @@ enum ath79_mach_type {
        ATH79_MACH_ALFA_NX,             /* ALFA Network N2/N5 board */
        ATH79_MACH_ALL0258N,            /* Allnet ALL0258N */
 @@ -20,6 +20,7 @@ enum ath79_mach_type {
        ATH79_MACH_ALFA_NX,             /* ALFA Network N2/N5 board */
        ATH79_MACH_ALL0258N,            /* Allnet ALL0258N */