[package] appweb: fix linking against libdl
authorFlorian Fainelli <florian@openwrt.org>
Wed, 1 Aug 2012 18:40:25 +0000 (18:40 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 1 Aug 2012 18:40:25 +0000 (18:40 +0000)
SVN-Revision: 32935

net/appweb/Makefile

index d52e7aebd95310d0721d5bcbbe0c4c955abc3b98..2437761e7adace87ad6a7f48908a585346a42170 100644 (file)
@@ -46,10 +46,22 @@ define Package/appweb/description
 endef
 
 CONFIGURE_ARGS += \
-       -q --defaults=release --shared --tune=size --without-php \
-       --without-ssl --disable-angel --disable-samples --disable-access-log \
-       --disable-complete-native --disable-complete-cross --webdir=/www \
-       --logdir=/var/log --port=8000 --sslPort=8443 --config=flat
+       -q \
+       --defaults=release \
+       --shared \
+       --tune=size \
+       --without-php \
+       --without-ssl \
+       --disable-angel \
+       --disable-samples \
+       --disable-access-log \
+       --disable-complete-native \
+       --disable-complete-cross \
+       --webdir=/www \
+       --logdir=/var/log \
+       --port=8000 \
+       --sslPort=8443 \
+       --config=flat
 
 define Build/Prepare
        tar xzf "$(DL_DIR)/$(PKG_SOURCE)" --strip-components 1 -C "$(PKG_BUILD_DIR)"
@@ -60,7 +72,9 @@ define Build/Configure
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               BLD_CC_DYN_LOAD=1
 endef
 
 define Package/appweb/install