[package] base-files: Don't pass '--set-worker /lib/hotplug2/worker_fork.so' to hotpl...
authorVasilis Tsiligiannis <acinonyx@openwrt.gr>
Fri, 11 Jan 2013 13:20:51 +0000 (13:20 +0000)
committerVasilis Tsiligiannis <acinonyx@openwrt.gr>
Fri, 11 Jan 2013 13:20:51 +0000 (13:20 +0000)
SVN-Revision: 35095

package/base-files/Makefile
package/base-files/files/lib/preinit/30_device_fs_daemons

index 0e72c188d56a039ee280b2ee7708fbfc0d9584d7..5bb2e25652f0ea132932e1c2e14cd95d1b29b3a7 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2012 OpenWrt.org
+# Copyright (C) 2007-2013 OpenWrt.org
 # Copyright (C) 2010 Vertical Communications
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=123
+PKG_RELEASE:=124
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 5b3e2ad00021c30de3291a79bf22e367eb807a41..8379e5e74f4d2fcb54e1d34b7127a5e34f4f98ac 100644 (file)
@@ -1,5 +1,5 @@
 #!/bin/sh
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 # Copyright (C) 2010 Vertical Communications
 
 init_devfs() {
@@ -8,8 +8,8 @@ init_devfs() {
 
 init_hotplug2() {
     [ -c /dev/console ] || mknod /dev/console c 5 1
-    /sbin/hotplug2 --set-worker /lib/hotplug2/worker_fork.so --set-rules-file /etc/hotplug2-init.rules --no-persistent --set-coldplug-cmd /sbin/udevtrigger
-    /sbin/hotplug2 --set-worker /lib/hotplug2/worker_fork.so --set-rules-file /etc/hotplug2-init.rules --persistent &
+    /sbin/hotplug2 --set-rules-file /etc/hotplug2-init.rules --no-persistent --set-coldplug-cmd /sbin/udevtrigger
+    /sbin/hotplug2 --set-rules-file /etc/hotplug2-init.rules --persistent &
 }
 
 init_udev() {