merge build system changes from trunk to 8.09
authorFelix Fietkau <nbd@openwrt.org>
Sat, 11 Oct 2008 11:02:23 +0000 (11:02 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 11 Oct 2008 11:02:23 +0000 (11:02 +0000)
SVN-Revision: 12952

package/libnl/patches/150-fix-libnl-pc-config.patch [new file with mode: 0644]
tools/automake/Makefile
tools/automake/files/aclocal [new file with mode: 0644]
tools/pkg-config/files/pkg-config

diff --git a/package/libnl/patches/150-fix-libnl-pc-config.patch b/package/libnl/patches/150-fix-libnl-pc-config.patch
new file mode 100644 (file)
index 0000000..ccdbc35
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/libnl-1.pc.in b/libnl-1.pc.in
+index 7ac8413..66a7cd9 100644
+--- a/libnl-1.pc.in
++++ b/libnl-1.pc.in
+@@ -1,7 +1,7 @@
+ prefix=@prefix@
+ exec_prefix=@prefix@
+ libdir=@libdir@
+-includedir=@prefix@/include
++includedir=@includedir@
+ Name: libnl
+ Description: Convenience library for netlink sockets
index cf39cbda8bc82845b23170592e5a330bcc5e67fe..2b8a6f3450109331d1ace7cd6150d6c101797857 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -27,6 +27,9 @@ endef
 
 define Build/Install
        $(MAKE) -C $(PKG_BUILD_DIR) install
 
 define Build/Install
        $(MAKE) -C $(PKG_BUILD_DIR) install
+       mv $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal.real
+       $(INSTALL_BIN) ./files/aclocal $(STAGING_DIR_HOST)/bin
+       ln -f $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.9
 endef
 
 define Build/Clean
 endef
 
 define Build/Clean
diff --git a/tools/automake/files/aclocal b/tools/automake/files/aclocal
new file mode 100644 (file)
index 0000000..60278e2
--- /dev/null
@@ -0,0 +1,10 @@
+#!/usr/bin/env sh
+if [ -d ${STAGING_DIR}/host/share/aclocal ]; then
+    aclocal_include_dirs="-I ${STAGING_DIR}/host/share/aclocal"
+else
+    aclocal_include_dirs=
+fi
+if [ -d ${STAGING_DIR}/usr/share/aclocal ]; then
+    aclocal_include_dirs="$aclocal_include_dirs -I ${STAGING_DIR}/usr/share/aclocal"
+fi
+aclocal.real $aclocal_include_dirs $@
index 31cfd0d83dc94892a85b4f18c9bb2004296d64b0..a3d73700f9a99b5dac7287c2448cd01f2824667c 100755 (executable)
@@ -1,3 +1,3 @@
 #!/bin/sh
 
 #!/bin/sh
 
-pkg-config.real $@ --define-variable=libdir=${STAGING_DIR}/usr/lib --define-variable=includedir=${STAGING_DIR}/usr/include
+pkg-config.real $@ --define-variable=prefix=${STAGING_DIR}/usr/ --define-variable=exec_prefix=${STAGING_DIR}/usr/