[packages] sane-backends: update to 1.0.22 (#9706), thanks simnet
authorStephen Walker <stephendwalker@gmail.com>
Sun, 17 Jul 2011 09:45:40 +0000 (09:45 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Sun, 17 Jul 2011 09:45:40 +0000 (09:45 +0000)
 * add working Debian mirror
 * build without SNMP support
 * refresh patches

SVN-Revision: 27634

utils/sane-backends/Makefile
utils/sane-backends/patches/001-remove-unneeded.patch
utils/sane-backends/patches/010-dont-add-host-include-path.patch
utils/sane-backends/patches/020-non-i386-qcam.patch

index 96fc586aaf9bb60ad0aee859e68be86064540f83..fa8f05b72755b915e7bcfb04a9ac501321cb8427 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sane-backends
-PKG_VERSION:=1.0.20
-PKG_RELEASE:=3
+PKG_VERSION:=1.0.22
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.sane-project.org/pub/sane/$(PKG_NAME)-$(PKG_VERSION)/
-PKG_MD5SUM:=a0cfdfdebca2feb4f2ba5d3418b15a42
+PKG_SOURCE_URL:=ftp://ftp.sane-project.org/pub/sane/$(PKG_NAME)-$(PKG_VERSION) \
+       https://alioth.debian.org/frs/download.php/3503
+PKG_MD5SUM:=fadf56a60f4776bfb24491f66b617cf5
 
 PKG_FIXUP:=libtool
 PKG_INSTALL:=1
@@ -79,6 +80,7 @@ CONFIGURE_ARGS+= \
        --disable-latex \
        --without-gphoto2 \
        --disable-debug \
+       --without-snmp
 
 define Build/Configure
        mkdir -p $(PKG_BUILD_DIR)/backend/.libs
index ec45a4e12e9fcf32242713fcfe95fd4a97246fda..3eeca3d63084fe91cd038c0c4da6fc4325cd4abc 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -244,7 +244,7 @@ target_alias = @target_alias@
+@@ -293,7 +293,7 @@ target_alias = @target_alias@
  top_build_prefix = @top_build_prefix@
  top_builddir = @top_builddir@
  top_srcdir = @top_srcdir@
index 327348d29fe6518d5a53d7e30c5cf1e1826e262c..c7caf2572a4dcd3ebf188bb6e77ce5de98fb6082 100644 (file)
@@ -1,8 +1,6 @@
-diff --git a/configure b/configure
-index cc79209..5f22d58 100755
 --- a/configure
 +++ b/configure
-@@ -5019,9 +5019,6 @@ else
+@@ -5070,9 +5070,6 @@ else
  fi
  
  
index 2dbb7d87edebbb3f27ee5997c313e993703a75ed..aa64d43f4f2d5f2355138e61c23f745c9aae2d65 100644 (file)
@@ -1,5 +1,5 @@
---- ./backend/qcam.c.orig      2009-12-01 06:11:04.000000000 +0000
-+++ ./backend/qcam.c   2009-12-01 15:12:40.000000000 +0000
+--- a/backend/qcam.c
++++ b/backend/qcam.c
 @@ -105,6 +105,17 @@
  
  #include "qcam.h"