build: Allow kernel modules to set build ID debug symbol
authorFelix Fietkau <nbd@openwrt.org>
Fri, 30 Oct 2015 15:20:12 +0000 (15:20 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 30 Oct 2015 15:20:12 +0000 (15:20 +0000)
This change adds support for specifying a build ID for kernel modules.
This is done by setting PKG_BUILD_ID to a hexadecimal string, which will
then be passed to the kernel linker. In addition, when this flag is set,
the build ID debug symbol (.note.gnu.build-id) will not be stripped from
the kernel module. This symbol is exported in sysfs by the kernel (if
the kernel is compiled with CONFIG_KALLSYMS) and so can be used to
uniquely identify a version of a kernel module in a running kernel. This
is useful for keeping track of different versions of a module when doing
experiments and development.

Modules that specify the build ID will be ~100 bytes larger (depending
on the length of the build ID specified). There is no size difference
for kernel modules that do not set this variable.

Signed-off-by: Toke Høiland-Jørgensen <toke@toke.dk>
SVN-Revision: 47290

include/kernel-defaults.mk
rules.mk
scripts/strip-kmod.sh

index 24d26308b129b5202afa6bca61fbd3806ea6d916..d37787a44b554e54c81971b4e93b2ad0c0295909 100644 (file)
@@ -11,7 +11,8 @@ KERNEL_MAKEOPTS := -C $(LINUX_DIR) \
        ARCH="$(LINUX_KARCH)" \
        KBUILD_HAVE_NLS=no \
        CONFIG_SHELL="$(BASH)" \
-       $(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='')
+       $(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='') \
+       $(if $(PKG_BUILD_ID),LDFLAGS_MODULE=--build-id=0x$(PKG_BUILD_ID))
 
 ifdef CONFIG_STRIP_KERNEL_EXPORTS
   KERNEL_MAKEOPTS += \
index 819bea5f5a50febc91199300ee8d38d1e6d50e5e..7710fb4d9dfcae3d5a3874f4cfe39edd3258a957 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -273,8 +273,9 @@ else
       STRIP:=$(STAGING_DIR_HOST)/bin/sstrip
     endif
   endif
-  RSTRIP:= \
+  RSTRIP= \
     export CROSS="$(TARGET_CROSS)" \
+               $(if $(PKG_BUILD_ID),KEEP_BUILD_ID=1) \
                $(if $(CONFIG_KERNEL_KALLSYMS),NO_RENAME=1) \
                $(if $(CONFIG_KERNEL_PROFILING),KEEP_SYMBOLS=1); \
     NM="$(TARGET_CROSS)nm" \
index 13e6b58007f92fa870afcb58da9ac88df7957c19..e3f13bee4766d6611bb526a6b867ee0a3d48f805 100755 (executable)
@@ -18,11 +18,14 @@ else
        ARGS="-x -G __this_module --strip-unneeded"
 fi
 
+if [ -z "$KEEP_BUILD_ID" ]; then
+    ARGS="$ARGS -R .note.gnu.build-id"
+fi
+
 ${CROSS}objcopy \
        -R .comment \
        -R .pdr \
        -R .mdebug.abi32 \
-       -R .note.gnu.build-id \
        -R .gnu.attributes \
        -R .reginfo \
        $ARGS \