motion: revert (#1868)
authorOliver Ertl <oliver@ertl-net.net>
Mon, 16 Jul 2007 20:39:13 +0000 (20:39 +0000)
committerOliver Ertl <oliver@ertl-net.net>
Mon, 16 Jul 2007 20:39:13 +0000 (20:39 +0000)
SVN-Revision: 8008

multimedia/motion/Makefile
multimedia/motion/patches/001-ffmpeg.patch
multimedia/motion/patches/002-honor_cppflags.patch
multimedia/motion/patches/003-sn9c102-common-buffer.patch

index 04ea26a0a15829567d96c53d4ce416582be27bf9..9d2d10e451568f0341bbc1907c4f7b6ce5e8a73e 100644 (file)
@@ -9,12 +9,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=motion
-PKG_VERSION:=3.2.7
+PKG_VERSION:=20070331-051001
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/motion
-PKG_MD5SUM:=b4af6e10532fcdec89060bc61a27fc3a
+PKG_SOURCE_URL:=http://www.lavrsen.dk/sources/motion-daily \
+               @SF/motion
+PKG_MD5SUM:=16e58186022dfee1c0dcaf03cf5393e5
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
index 3489ef23e63445a790ae555bf78225f92326ee67..50c57484ccebeb1962d96ecbb444fe3f3f87c290 100644 (file)
@@ -1,8 +1,7 @@
-Index: motion-3.2.7/motion.c
-===================================================================
---- motion-3.2.7.orig/motion.c 2007-06-11 08:27:27.000000000 +0100
-+++ motion-3.2.7/motion.c      2007-06-11 08:27:35.000000000 +0100
-@@ -1279,6 +1279,7 @@
+diff -x .svn -ruN motion-3.2.8.old/motion.c motion-3.2.8/motion.c
+--- motion-3.2.8.old/motion.c  2007-03-31 12:54:31.000000000 +0200
++++ motion-3.2.8/motion.c      2007-03-31 13:08:27.000000000 +0200
+@@ -1282,6 +1282,7 @@
                 * httpd-control snaps are always enabled.
                 */
  
@@ -10,7 +9,7 @@ Index: motion-3.2.7/motion.c
                /* time_current_frame is used both for snapshot and timelapse features */
                time_current_frame = cnt->currenttime;
  
-@@ -1288,7 +1289,7 @@
+@@ -1291,7 +1292,7 @@
                        event(cnt, EVENT_IMAGE_SNAPSHOT, newimg, NULL, NULL, cnt->currenttime_tm);
                        cnt->snapshot = 0;
                }
@@ -19,7 +18,7 @@ Index: motion-3.2.7/motion.c
  
        /***** MOTION LOOP - TIMELAPSE FEATURE SECTION *****/
  
-@@ -1363,9 +1364,9 @@
+@@ -1366,9 +1367,9 @@
                        event(cnt, EVENT_TIMELAPSEEND, NULL, NULL, NULL, cnt->currenttime_tm);
  
  
index 0c0ba13075b375ea121f9599912b8be0295f5384..322fb772d35f677d857ca673db60a5f7f5e1c646 100644 (file)
@@ -1,7 +1,6 @@
-Index: motion-3.2.7/Makefile.in
-===================================================================
---- motion-3.2.7.orig/Makefile.in      2007-06-11 08:26:33.000000000 +0100
-+++ motion-3.2.7/Makefile.in   2007-06-11 08:27:55.000000000 +0100
+diff -ruN motion-3.2.5.1-old/Makefile.in motion-3.2.5.1-new/Makefile.in
+--- motion-3.2.5.1-old/Makefile.in     2006-03-07 22:52:49.000000000 +0100
++++ motion-3.2.5.1-new/Makefile.in     2006-03-27 22:04:34.000000000 +0200
 @@ -32,6 +32,7 @@
  ################################################################################
  CFLAGS       = @CFLAGS@ -Wall -DVERSION=\"$(VERSION)\" -D_REENTRANT \
@@ -10,7 +9,7 @@ Index: motion-3.2.7/Makefile.in
  LDFLAGS      = @LDFLAGS@
  LIBS         = @LIBS@ 
  VIDEO_OBJ    = @VIDEO@
-@@ -119,7 +120,7 @@
+@@ -115,7 +116,7 @@
  ################################################################################
  $(DEPEND_FILE): *.h $(SRC)
        @echo "Generating dependencies, please wait..."
index e43a1c044288b53e4ffca81940c909baff66b610..8a9693c70c5eb0ef549654dad321169a9efb52c9 100644 (file)
@@ -1,7 +1,7 @@
-Index: motion-3.2.7/motion.c
+Index: motion-3.2.8/motion.c
 ===================================================================
---- motion-3.2.7.orig/motion.c 2007-06-11 08:27:35.000000000 +0100
-+++ motion-3.2.7/motion.c      2007-06-11 08:28:30.000000000 +0100
+--- motion-3.2.8/motion.c      (revision 174)
++++ motion-3.2.8/motion.c      (working copy)
 @@ -474,8 +474,8 @@
        cnt->imgs.shotstamp = mymalloc(sizeof(int));