add better working-g++ check (patch from #2017)
authorFelix Fietkau <nbd@openwrt.org>
Mon, 23 Jul 2007 02:56:30 +0000 (02:56 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 23 Jul 2007 02:56:30 +0000 (02:56 +0000)
SVN-Revision: 8118

include/prereq-build.mk

index 6311e601ba46410bad706961fdac380adc12d81d..c31020c3211d528acca14d8d4a1a233652dfb1d6 100644 (file)
@@ -52,7 +52,8 @@ $(eval $(call Require,working-gcc, \
 
 define Require/working-g++
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ -
+               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ - && \
+               $(TMP_DIR)/a.out
 endef
 
 $(eval $(call Require,working-g++, \