this patch fixes libupnp parallel build and cleans the Makefile a
authorTravis Kemen <thepeople@openwrt.org>
Thu, 18 Feb 2010 00:46:17 +0000 (00:46 +0000)
committerTravis Kemen <thepeople@openwrt.org>
Thu, 18 Feb 2010 00:46:17 +0000 (00:46 +0000)
little.

-Raphael

SVN-Revision: 19697

libs/libupnp/Makefile

index d87fa682f5aca79d0670751cf5ce0bba0cbd6cab..76d283aa29f58da278f518cde469e8a37fdc8811 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,15 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libupnp
 PKG_VERSION:=1.6.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/pupnp
 PKG_MD5SUM:=8918dcf7428cd119d0c8275765ff2833
 
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libupnp/Default
@@ -31,11 +34,10 @@ define Package/libupnp
 endef
 
 define Package/libupnp/description
-        The portable SDK for UPnP Devices (libupnp) provides developers with an
-       API and open source code for building control points, devices, and
-       bridges that are compliant with Version 1.0 of the  Universal Plug and
-       Play Device Architecture Specification and support several operating
-       systems like Linux, *BSD, Solaris and others.
+The portable SDK for UPnP Devices (libupnp) provides developers with an API and
+open source code for building control points, devices, and bridges that are
+compliant with Version 1.0 of the  Universal Plug and Play Device Architecture
+Specification.
 endef
 
 define Package/libupnp-sample
@@ -45,8 +47,7 @@ define Package/libupnp-sample
 endef
 
 define Package/libupnp-sample/description
-       TVcontrolpoint & tvdevice sample applications
-       run inside /etc/upnp-tvdevice/
+TVcontrolpoint & tvdevice sample applications run inside /etc/upnp-tvdevice/
 endef
 
 define Build/Configure
@@ -58,26 +59,20 @@ endef
 
 TARGET_CFLAGS += $(FPIC)
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CCOPT="$(TARGET_CFLAGS)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-       $(MAKE) -C $(PKG_BUILD_DIR)/upnp/sample/ upnp_tv_device upnp_tv_ctrlpt
-endef
-
 define Build/Compile/libupnp-sample
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CCOPT="$(TARGET_CFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                check
+       $(MAKE) -C $(PKG_BUILD_DIR)/upnp/sample \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               upnp_tv_device upnp_tv_ctrlpt
 endef
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/upnp $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{ixml,threadutil,upnp}.{a,so*} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{ixml,threadutil,upnp}.{a,so*,la} $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libupnp.pc $(1)/usr/lib/pkgconfig/
 endef