[package] update to polarssl 0.12.0 (#5633)
authorFlorian Fainelli <florian@openwrt.org>
Wed, 5 Aug 2009 21:56:38 +0000 (21:56 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 5 Aug 2009 21:56:38 +0000 (21:56 +0000)
SVN-Revision: 17136

libs/polarssl/Makefile
libs/polarssl/patches/100-shared.patch
libs/polarssl/patches/110-make.patch

index d05310096efec8a0b8fe0daa5da439b4b583dd7f..d759dcddf0306db8e51dde872e60e9918bc2cf20 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=polarssl
-PKG_VERSION:=0.11.1
+PKG_VERSION:=0.12.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-gpl.tgz
 PKG_SOURCE_URL:=http://polarssl.org/code/releases/
-PKG_MD5SUM:=885d70f15d31eb736975e5473d8ea7ec
+PKG_MD5SUM:=585db0934ee507ff818be74305103e70
 
 include $(INCLUDE_DIR)/package.mk
 
index 9dee3c1699cffc9e4f01b8c677ccb3baa60cfa77..a57cff3a99b2b336a6dac0fc4093c753f2f65869 100644 (file)
@@ -1,5 +1,6 @@
---- polarssl-0.10.1.orig/library/Makefile      2009-01-11 00:31:23.000000000 +0100
-+++ polarssl-0.10.1/library/Makefile   2009-03-05 15:11:20.352419296 +0100
+diff -pruN polarssl-0.12.0.orig/library/Makefile polarssl-0.12.0/library/Makefile
+--- polarssl-0.12.0.orig/library/Makefile      2009-03-28 18:53:03.000000000 +0100
++++ polarssl-0.12.0/library/Makefile   2009-08-05 17:53:55.000000000 +0200
 @@ -29,7 +29,7 @@ OBJS=        aes.o           arc4.o          base64.o        \
  
  .SILENT:
index 8fefac8e752daa9f9000ef45e255514034ee1940..7ca926b2740832c7c566728c5780ce9826d4d8c7 100644 (file)
@@ -1,13 +1,30 @@
---- polarssl-0.10.1.orig/Makefile      2009-01-04 17:05:10.000000000 +0100
-+++ polarssl-0.10.1/Makefile   2009-03-05 15:11:20.356675557 +0100
-@@ -5,8 +5,8 @@ PREFIX=polarssl_
+diff -pruN polarssl-0.12.0.orig/Makefile polarssl-0.12.0/Makefile
+--- polarssl-0.12.0.orig/Makefile      2009-07-28 22:29:34.000000000 +0200
++++ polarssl-0.12.0/Makefile   2009-08-05 17:52:14.000000000 +0200
+@@ -5,9 +5,9 @@ PREFIX=polarssl_
  .SILENT:
  
  all:
 -      cd library  && make all && cd ..
 -      cd programs && make all && cd ..
+-      cd tests && make all && cd ..
 +      cd library  && $(MAKE) all && cd ..
 +      cd programs && $(MAKE) all && cd ..
++      #cd tests && $(MAKE) all && cd ..
  
  install:
        mkdir -p $(DESTDIR)/include/polarssl
+@@ -26,9 +26,9 @@ install:
+       done
+ clean:
+-      cd library  && make clean && cd ..
+-      cd programs && make clean && cd ..
+-      cd tests && make clean && cd ..
++      cd library  && $(MAKE) clean && cd ..
++      cd programs && $(MAKE) clean && cd ..
++      #cd tests && $(MAKE) clean && cd ..
+ check:
+-      ( cd tests && make check )
++      ( cd tests && $(MAKE) check )