packages/neon: force use of LFS and 64-bit off_t here as well
authorNicolas Thill <nico@openwrt.org>
Mon, 7 Nov 2011 23:45:59 +0000 (23:45 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 7 Nov 2011 23:45:59 +0000 (23:45 +0000)
fixes subversion segfaults after r28760, r28763, r28764 & r28765

SVN-Revision: 28842

libs/neon/Makefile

index 50e4a4958f613dba9b12898d30af38dc76c839ea..10c390fb02c3e639bcec60cf28944098eca6f948 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=neon
 PKG_VERSION:=0.29.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.webdav.org/neon
@@ -29,6 +29,7 @@ define Package/libneon
 endef
 
 TARGET_CFLAGS += $(FPIC)
+TARGET_CPPFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
 
 CONFIGURE_ARGS += \
        --enable-shared \