Prevent asterisk from using k6 optimisations (#1378), fixes ppc buildbot error as...
authorFlorian Fainelli <florian@openwrt.org>
Wed, 28 Feb 2007 17:34:06 +0000 (17:34 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 28 Feb 2007 17:34:06 +0000 (17:34 +0000)
SVN-Revision: 6434

net/asterisk/patches/13-Makefile-codecs-gsm.patch

index 23c7e0babf74f8b6903448360dd4908b9b764619..ccdae5bfcb96f0fef7f7f5205f91e8ea2a1a1292 100644 (file)
@@ -1,38 +1,47 @@
-diff -Nru asterisk-1.2.14.org/codecs/gsm/Makefile asterisk-1.2.14/codecs/gsm/Makefile
---- asterisk-1.2.14.org/codecs/gsm/Makefile    2006-07-24 19:05:56.000000000 +0200
-+++ asterisk-1.2.14/codecs/gsm/Makefile        2006-12-27 09:14:51.000000000 +0100
-@@ -241,6 +241,8 @@
+--- asterisk-1.2.14/codecs/gsm/Makefile.orig   2007-02-21 23:03:07.000000000 +0100
++++ asterisk-1.2.14/codecs/gsm/Makefile        2007-02-21 23:03:40.000000000 +0100
+@@ -241,6 +241,10 @@
  ifneq ($(shell uname -m),armv4l)
  ifneq ($(shell uname -m),sparc64)
  ifneq (${PROC},arm)
++ifneq (${PROC},armeb)
 +ifneq (${PROC},mipsel)
 +ifneq (${PROC},mips)
++ifneq (${PROC},ppc)
  ifneq ($(shell uname -m), parisc)
  ifneq ($(shell uname -m),s390)
  GSM_SOURCES+= $(SRC)/k6opt.s
-@@ -255,6 +257,8 @@
+@@ -255,6 +258,10 @@
  endif
  endif
  endif
 +endif
++endif
++endif
 +endif
  
  TOAST_SOURCES = $(SRC)/toast.c                \
                $(SRC)/toast_lin.c      \
-@@ -308,6 +312,8 @@
+@@ -308,6 +314,11 @@
  ifneq ($(shell uname -m), alpha)
  ifneq ($(shell uname -m), sparc64)
  ifneq ($(shell uname -m), armv4l)
++ifneq (${PROC}, arm)
++ifneq (${PROC}, armeb)
 +ifneq (${PROC}, mipsel)
 +ifneq (${PROC}, mips)
++ifneq (${PROC}, ppc)
  ifneq ($(shell uname -m), parisc)
  ifneq ($(shell uname -m),s390)
  GSM_OBJECTS+= $(SRC)/k6opt.o
-@@ -321,6 +327,8 @@
+@@ -321,6 +331,11 @@
  endif
  endif
  endif
 +endif
++endif
++endif
++endif
 +endif
  
  TOAST_OBJECTS =       $(SRC)/toast.o          \