[package] update amule to 2.2.6 (#5914)
authorFlorian Fainelli <florian@openwrt.org>
Mon, 28 Sep 2009 19:06:56 +0000 (19:06 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 28 Sep 2009 19:06:56 +0000 (19:06 +0000)
SVN-Revision: 17789

net/amule/Makefile
net/amule/patches/001-no_backtrace.patch

index 830b4947341d256ea79c0ac4c1c28ff6550360a6..0fa24709c1aa81f35b2d6a4dae9e1dd9c81197e7 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aMule
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aMule
-PKG_VERSION:=2.2.5
+PKG_VERSION:=2.2.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/amule
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/amule
-PKG_MD5SUM:=
+PKG_MD5SUM:=530d9b48187e36f78fc21bb19e94326d
 
 PKG_BUILD_DEPENDS:=libgd
 
 
 PKG_BUILD_DEPENDS:=libgd
 
index f4882913791b51134628931298ec9ccb5ed499aa..eb0d9570a8760e184739261f10569ccdb6aff18c 100644 (file)
@@ -1,13 +1,11 @@
-Index: aMule-2.1.3/src/libs/common/MuleDebug.cpp
-===================================================================
---- aMule-2.1.3.orig/src/libs/common/MuleDebug.cpp     2007-09-23 21:47:41.000000000 +0200
-+++ aMule-2.1.3/src/libs/common/MuleDebug.cpp  2007-09-23 21:47:41.000000000 +0200
-@@ -151,7 +151,7 @@
+--- a/src/libs/common/MuleDebug.cpp
++++ b/src/libs/common/MuleDebug.cpp
+@@ -168,7 +168,7 @@ wxString get_backtrace(unsigned n)
        return walker.m_trace;
  }
  
 -#elif defined(__LINUX__)
 +#elif defined(__LINUX__) && !defined(__UCLIBC__)
  
        return walker.m_trace;
  }
  
 -#elif defined(__LINUX__)
 +#elif defined(__LINUX__) && !defined(__UCLIBC__)
  
- #if HAVE_BFD
+ #ifdef HAVE_BFD