[package] update stunnel to 4.27 (#5650)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 9 Aug 2009 10:44:52 +0000 (10:44 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 9 Aug 2009 10:44:52 +0000 (10:44 +0000)
SVN-Revision: 17193

net/stunnel/Makefile
net/stunnel/files/stunnel.init
net/stunnel/patches/100-cross-compile.patch
net/stunnel/patches/101-no-comp.patch
net/stunnel/patches/102-no-ssl2.patch

index 93161e93863435dbd6d906a4ae1aab1bfc5fa9c1..ec01f399fe4bc62a9939c8bcac8ffd583fdd4f85 100644 (file)
@@ -2,9 +2,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=stunnel
-PKG_VERSION:=4.25
+PKG_VERSION:=4.27
 PKG_RELEASE:=1
-PKG_MD5SUM:=7f00799f43910c0362df0e69c65965aa
+PKG_MD5SUM:=3c655d815576f50046a1c28744b88681
 PKG_SOURCE_URL:=http://www.stunnel.org/download/stunnel/src/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 
@@ -23,7 +23,7 @@ define Package/stunnel/description
        connections inside SSL (Secure Sockets Layer) available on both Unix
        and Windows. Stunnel can allow you to secure non-SSL aware daemons and
        protocols (like POP, IMAP, LDAP, etc) by having Stunnel provide the
-       encryption, requiring no changes to the daemon's code. 
+       encryption, requiring no changes to the daemon's code.
 endef
 
 
@@ -35,7 +35,7 @@ define Build/Configure
        )
 endef
 
-define Build/Compile   
+define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)/etc/stunnel
        echo '#dummy' > $(PKG_INSTALL_DIR)/etc/stunnel/stunnel.pem
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -43,11 +43,11 @@ define Build/Compile
                all install
 endef
 
-define Package/stunnel/install 
+define Package/stunnel/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/stunnel $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/lib/stunnel
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/stunnel/libstunnel.so $(1)/usr/lib/stunnel/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/stunnel/libstunnel.so $(1)/usr/lib/stunnel/
        $(INSTALL_DIR) $(1)/etc/stunnel
        $(INSTALL_CONF) ./files/stunnel.conf $(1)/etc/stunnel/stunnel.conf
        $(INSTALL_DIR) $(1)/etc/init.d
index e9ebfebf87d87579e4de8e4c4083e234f65bb4ec..3929335ded58881341d85ebef85be23f9ef4d721 100644 (file)
@@ -3,8 +3,7 @@
 
 START=90
 
-case "$1" in
-    start|boot)
+start() {
        if [ -s "/etc/stunnel/stunnel.pem" ]; then
                chmod og-rwx /etc/stunnel/stunnel.pem
                stunnel
@@ -22,9 +21,9 @@ case "$1" in
                        stunnel) &
                }
        fi
-       ;;
-    stop)
+}
+
+stop() {
        killall stunnel
        killall -9 stunnel
-       ;;
-esac
+}
index c7452317d986c3ac7125f7a8238ed458c8c667d7..52052a02e097335408c04d64d2eb73acca281385 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -20898,56 +20898,56 @@
+@@ -21536,56 +21536,56 @@ _ACEOF
  fi
  rm -f conftest*
  
  
  
  { echo "$as_me:$LINENO: **************************************** entropy" >&5
-@@ -23394,8 +23394,8 @@
+@@ -24033,8 +24033,8 @@ _ACEOF
  
  
  # Add SSL includes and libraries
index a122d0e896deb7f0c05c9a63f477919407567df6..d9950359f935ce16833684ebfbf8cde3ba1eb082 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/ssl.c
 +++ b/src/ssl.c
-@@ -62,13 +62,16 @@
+@@ -62,13 +62,16 @@ void ssl_init(void) { /* init SSL before
  }
  
  void ssl_configure(void) { /* configure global SSL settings */
@@ -17,7 +17,7 @@
      int id=0;
      COMP_METHOD *cm=NULL;
      char *name="unknown";
-@@ -97,6 +100,7 @@
+@@ -97,6 +100,7 @@ static void init_compression(void) {
          die(1);
      }
      s_log(LOG_INFO, "Compression enabled using %s method", name);
index 45c4215a5c780675484c0898cea7f2955a4df255..c7dca9ea34682593363b7bdd7e0c16e4015fb75e 100644 (file)
@@ -1,13 +1,13 @@
 --- a/src/options.c
 +++ b/src/options.c
-@@ -1127,8 +1127,10 @@
-             section->client_method=SSLv23_client_method;
-             section->server_method=SSLv23_server_method;
+@@ -1166,8 +1166,10 @@ static char *service_options(CMD cmd, LO
+             section->client_method=(SSL_METHOD *)SSLv23_client_method();
+             section->server_method=(SSL_METHOD *)SSLv23_server_method();
          } else if(!strcasecmp(arg, "SSLv2")) {
 +#ifndef OPENSSL_NO_SSL2
-             section->client_method=SSLv2_client_method;
-             section->server_method=SSLv2_server_method;
+             section->client_method=(SSL_METHOD *)SSLv2_client_method();
+             section->server_method=(SSL_METHOD *)SSLv2_server_method();
 +#endif
          } else if(!strcasecmp(arg, "SSLv3")) {
-             section->client_method=SSLv3_client_method;
-             section->server_method=SSLv3_server_method;
+             section->client_method=(SSL_METHOD *)SSLv3_client_method();
+             section->server_method=(SSL_METHOD *)SSLv3_server_method();