add Content-Disposition workaround (closes: #2048), bump release number
authorNicolas Thill <nico@openwrt.org>
Tue, 21 Aug 2007 21:43:58 +0000 (21:43 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 21 Aug 2007 21:43:58 +0000 (21:43 +0000)
SVN-Revision: 8458

utils/haserl/Makefile
utils/haserl/patches/101-ignore_content_disposition.patch [new file with mode: 0644]

index aa0413e25ec5356bfd60f2435fb580569843e7ed..35eff9ff08f147f4de448e596e6f6b6b8f592a5d 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=haserl
 PKG_VERSION:=0.8.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/haserl
diff --git a/utils/haserl/patches/101-ignore_content_disposition.patch b/utils/haserl/patches/101-ignore_content_disposition.patch
new file mode 100644 (file)
index 0000000..46ac9a4
--- /dev/null
@@ -0,0 +1,18 @@
+Index: haserl-0.8.0/src/haserl.c
+===================================================================
+--- haserl-0.8.0.orig/src/haserl.c     2007-06-04 13:22:30.973146648 +0200
++++ haserl-0.8.0/src/haserl.c  2007-06-04 13:22:31.039136616 +0200
+@@ -479,9 +479,12 @@
+               line=LineToStr(&qs[offset], cl-offset);
+               if (strncasecmp(&qs[offset], "Content-Disposition", 19) != 0) {
+                       /* hmm... content disposition was not where we expected it */
++                      /* Be kind to Opera 9.10 and just ignore this block     */
++                              /*
+                       PrintParseError ("Content-Disposition Missing", 0);
+                       free(ct);
+-                      return(-1);
++                              */
++                      continue;
+                       }
+               /* Found it, so let's go find "name="                           */
+               if (!(envname=strstr(&qs[offset], "name="))) {