Add kmod-ppp-synctty (#2231)
authorFlorian Fainelli <florian@openwrt.org>
Wed, 22 Aug 2007 08:31:49 +0000 (08:31 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 22 Aug 2007 08:31:49 +0000 (08:31 +0000)
SVN-Revision: 8459

package/kernel/modules/network.mk
target/linux/generic-2.4/config-template

index a7b93e1d4c28263ba03dbeeccdffd7862235594c..6da38e4e05c6e8b5e14f2a8c317b311ece5bae56 100644 (file)
@@ -189,6 +189,19 @@ endef
 $(eval $(call KernelPackage,ppp))
 
 
 $(eval $(call KernelPackage,ppp))
 
 
+define KernelPackage/ppp-synctty
+  TITLE:=PPP sync tty support
+  DESCRIPTION:=\
+       Kernel modules for PPP sync tty support
+  DEPENDS:=kmod-ppp
+  KCONFIG:=CONFIG_PPP_SYNC_TTY
+  SUBMENU:=$(NSMENU)
+  FILES:=$(LINUX_DIR)/drivers/net/ppp_synctty.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,40,ppp_synctty)
+endef
+$(eval $(call KernelPackage,ppp-synctty))
+
+
 define KernelPackage/pppoe
   TITLE:=PPPoE support
   DESCRIPTION:=\
 define KernelPackage/pppoe
   TITLE:=PPPoE support
   DESCRIPTION:=\
index 1607f0450860259e38a531bc6f144db1060d0143..9f33ef427ec6bc85fa7a9fa7d08b6cce3bf08cc5 100644 (file)
@@ -579,7 +579,7 @@ CONFIG_PPP_DEFLATE=m
 CONFIG_PPP_FILTER=y
 CONFIG_PPP_MPPE_MPPC=m
 # CONFIG_PPP_MULTILINK is not set
 CONFIG_PPP_FILTER=y
 CONFIG_PPP_MPPE_MPPC=m
 # CONFIG_PPP_MULTILINK is not set
-# CONFIG_PPP_SYNC_TTY is not set
+CONFIG_PPP_SYNC_TTY=m
 # CONFIG_PRISM54 is not set
 CONFIG_PROC_FS=y
 # CONFIG_QFMT_V2 is not set
 # CONFIG_PRISM54 is not set
 CONFIG_PROC_FS=y
 # CONFIG_QFMT_V2 is not set