fix kernel postinst scripts
authorFelix Fietkau <nbd@openwrt.org>
Sun, 30 Jul 2006 17:06:02 +0000 (17:06 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 30 Jul 2006 17:06:02 +0000 (17:06 +0000)
SVN-Revision: 4336

openwrt/package/kernel/Makefile

index b1155f4286672e164f259d5c7a5599ad8c5f1611..e5094ef01142360af222717947330a08963f97df 100644 (file)
@@ -45,8 +45,8 @@ define ModuleAutoLoad
        $(3) \
        if [ -n "$$$$$$$$modules" ]; then \
                mkdir -p $(2)/etc/modules.d; \
-               echo "#!/bin/sh" >> $(2)/CONTROL/postinst; \
-               echo "[ -z \"\$$$$$$$$IPKG_INSTROOT\" ] || exit" >> $(2)/CONTROL/postinst; \
+               echo "#!/bin/sh" > $(2)/CONTROL/postinst; \
+               echo "[ -z \"\$$$$$$$$IPKG_INSTROOT\" ] || exit 0" >> $(2)/CONTROL/postinst; \
                echo ". /etc/functions.sh" >> $(2)/CONTROL/postinst; \
                echo "load_modules $$$$$$$$modules" >> $(2)/CONTROL/postinst; \
                chmod 0755 $(2)/CONTROL/postinst; \